New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Running Windows (or anything else) on your Mac Discussion of Classic or running Windows, Linux and other OSes on the Mac.

Wifi Issues in Windows 7 on rMBP


Post Reply New Thread Subscribe

 
Thread Tools
khcrazy10

 
khcrazy10's Avatar
 
Member Since: Apr 04, 2013
Location: Canada
Posts: 32
khcrazy10 is on a distinguished road
Mac Specs: Macbook Pro Retina 15" 2.7 GHz Intel Core i7 with 16 GB DDR3 Ram running OS X 10.8.4 Mountain Lion

khcrazy10 is offline
Ok so I have the 15" Retina Macbook Pro 2.7 GHz with the 802.11 wireless N card. I dual booted Windows 7 Professional OEM copy on it yesterday and I've noticed some pretty slow speeds on my speed test. Right now my family is paying for a 50mb/s download speed and 3mb/s upload speed.

On the speed test (provided through my ISP's site and the only thing they'll take seriously if I call in about speed issues), the upload speed comes back fine but the download speed is cut down to a speed between 10 and 20mb/s. Lowest speed readout has been 2mb/s this morning.

The mac side shows a perfect speed test and I tried tethering my Android phone on the windows side to share its Wifi card and it comes back at the phone's max speed ability on the speed test.

Is there anything I can do to fix the speed on the windows side as I will be using it for my main school system while the mac side is there for audio and video work? Maybe a driver or something? I have the latest version of Boot Camp installed.

Thank you!
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 41,406
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, Yosemite

chscag is offline
You should be receiving the same download and upload speeds while in OS X and Windows 7. The only suggestions I have is to make sure you have everything setup correctly in Windows 7 and that you're using the latest Windows driver for your airport card. Use the control panel Boot Camp update utility to make sure you have the latest version of Boot Camp installed for Windows. Boot Camp updates may contain updated drivers.
QUOTE Thanks
khcrazy10

 
khcrazy10's Avatar
 
Member Since: Apr 04, 2013
Location: Canada
Posts: 32
khcrazy10 is on a distinguished road
Mac Specs: Macbook Pro Retina 15" 2.7 GHz Intel Core i7 with 16 GB DDR3 Ram running OS X 10.8.4 Mountain Lion

khcrazy10 is offline
Ok I tried reinstalling the drivers and it improved the speed... it wasn't until today that I got full network speed on the windows side though. It's possible it could have been my ISP since there's people in my house who have noticed a speed drop on SOME devices but not others but I'm not entirely sure. I'm curious as to why the mac side wouldn't be phased if that's the case.

Anyhow... it's magically working now after having shut it off and turned it back on a few times due to normal shutdown and startup. So yeah.
QUOTE Thanks

Post Reply New Thread Subscribe


« Blue screen on startup | Headphone/Mic Combo Jack Bootcamp Compatibility »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
iPad 2 WiFi Issues Valentina's Dad Internet, Networking, and Wireless 0 04-05-2012 12:46 PM
Today's the day to re-install WinXP on my Dell Desktop MYmacROX Running Windows (or anything else) on your Mac 8 02-24-2010 11:53 AM
OS X: My experience so far Delete Switcher Hangout 48 11-08-2009 03:01 PM
Safari and Facebook Problems MrTissues OS X - Apps and Games 7 02-26-2009 06:01 PM
Running Windows on Mac rickmahmoud Running Windows (or anything else) on your Mac 7 02-17-2008 12:31 AM

All times are GMT -4. The time now is 04:32 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?