Results 1 to 3 of 3
  1. #1

    Member Since
    Sep 29, 2010
    Problem booting boot camp or any startup disk
    I am running Snow Leopard on a 2.4GHz MacBook Pro, late 08 - early 09 model. I have been using boot camp to run Vista for the past year with no problem. This morning, I tried to start up Vista and it wasn't working. I got the option key screen to choose between OSX and Vista, but after choosing vista, the cursor blinks once and I get a black screen. The computer is quiet and nothing seems to be running.

    At first I thought it was a boot camp problem. So I went into OSX, de-partitioned the drive, and repartitioned it. I then stuck the Vista install disk in, and clicked through the boot camp assistant to reinstall. The computer restarted to begin the reinstall process, but instead of starting the install disk, it did the same thing - a single blip of cursor, and then a black screen.

    I'm not technically savvy, but that seems like it's not a Windows problem, but a firmware or EFI problem. The computer will run OSX, but it won't run boot camp and it won't start from a CD-ROM. The only other steps I've taken are to run Software Update and the Disk Utility from Safari. Neither helped. I'm out of warranty and would love to be able to fix it without spending tons of money. Any help is appreciated.

  2. #2

    Member Since
    Sep 29, 2010
    A few updates:

    I tried resetting the PRAM and SMC, neither of which worked.

    I ran the EFI update utility, which says the EFI is up to date.

    I have also since tried starting up from the Snow Leopard disk, which DOES work, so, to more precisely try to pinpoint the problem, I can boot both Snow Leopard and the Snow Leopard Startup Disk, but I cannot boot Windows Vista or the Windows Vista Startup Disk.

    The only thing I installed recently was Civilization V for Windows, about a week ago. I can't remember if I had switched to OSX and back since the install without having a problem, or if I just left it on Vista straight through the last week.

  3. #3

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Since you're able to boot from the Snow Leopard DVD, try this: Boot to Snow Leopard normally from your hard drive and go back into the Boot Camp assistant. Delete the Vista partition. In other words restore everything back to OS X. After that's completed, reboot the machine from your Snow Leopard DVD and run Disk Utility. Do a verify and repair for the entire hard drive. Let's see what it says.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Boot camp disappeared form Startup Disk
    By Steinlager in forum Running Windows (or anything else) on your Mac
    Replies: 0
    Last Post: 11-22-2014, 08:01 PM
  2. Can't see option menu when booting from startup disk
    By salanderisms in forum OS X - Operating System
    Replies: 10
    Last Post: 08-16-2012, 05:06 AM
  3. Not booting after locking startup disk on only drive
    By BearMoon in forum OS X - Operating System
    Replies: 12
    Last Post: 06-08-2012, 06:23 PM
  4. boot camp startup disk cannot be partitioned
    By WinVector in forum Running Windows (or anything else) on your Mac
    Replies: 1
    Last Post: 09-15-2009, 09:17 PM
  5. Boot Camp startup disk question
    By vell in forum Running Windows (or anything else) on your Mac
    Replies: 4
    Last Post: 03-28-2007, 09:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts