Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Running Windows (or anything else) on your Mac (http://www.mac-forums.com/forums/running-windows-anything-else-your-mac/)
-   -   No sound in Windows 7 after Boot Camp (IMAC MID 2010) (http://www.mac-forums.com/forums/running-windows-anything-else-your-mac/212761-no-sound-windows-7-after-boot-camp-imac-mid-2010-a.html)

mellocakes 08-28-2010 05:24 AM

No sound in Windows 7 after Boot Camp (IMAC MID 2010)
 
Hi,


I really have tried everything that i could find on forums and blogposts about getting the right driver for the sound. But nothing works.

I have an iMac 21,5" from May this year, I installed windows 7 with boot camp 3.0, and did everything as described. Every driver worked, exept the sound driver. I upraded boot camp to version 3.1, but without succes, I also tried to reinstall the drivers for several times from my Leopard os x disk.

But nothing seems to work.

When I open up the configuration for the sound, the thing says there is no device founded.
I even tried other music boxes, but with no succes.

I have Windows 7 in 32 bit.

The problem is that Windows cant't find any speakers, boxes, and even the build-in boxes from my iMac. When I open the control panel for "sound" in the configuration menu, I can see that there isn't any device installed.

How do I fix this? Should I get other drivers?

I have also tried installing the following drivers from the realtek site:

* Vista, Windows7 Driver (32/64bits) Driver only (Executable file) R2.51
And all the others with windows 7 on it..

*ATI HDMI Audio Device R2.49
-> This driver won't install properly: Just before it's finishing it says:


Quote:

---------------------------
Realtek High Definition Audio Driver - InstallShield Wizard
---------------------------
Er wordt geen stuurprogramma ondersteund in deze stuurprogrammabundel.
//There is no support for this OS in this OS bundel (i think it's translated in this way)//
---------------------------
OK
---------------------------
http://img835.imageshack.us/img835/9008/naamloosis.png

And, I also have noticed, that when i go in program files > Realtek > the .exe program won't do anything. I'm wondering if the driver does install correctly?

Has anyone advice?

Cheerio,

Mellocakes

(Now I remember why I choose a mac, there is no driver-rubbish. It just WORKS ;D)

chscag 08-28-2010 08:31 PM

The correct sound drivers are on your Snow Leopard DVD. If all the other drivers are working OK, the sound should likewise work. What is strange is that Windows 7 is saying that there is no sound device installed.

What happens when you open Control Panel, System, Hardware, and expand the hardware tree? Does it show a sound device at all? Or is there a ! (exclamation mark) over the device?

Here's a LINK that is from a search in these forums regarding your problem. You may be able to get some information that might be useful to you.

mellocakes 08-29-2010 04:37 AM

consta 11
 
http://img64.imageshack.us/img64/1989/deviceap.png

There is indeed an (!) on the symbol of High Defenition Audio Controll

mellocakes 08-29-2010 07:40 AM

I've reinstalled windows, but again with no succes. The same problems as described up here. The device manager gives the same yellow exclamation mark...

chscag 08-29-2010 11:31 PM

Your hardware tree is missing an entire device entry:

"Sound, Video, and Game Controllers"

That's the reason you have an ! over the entry for "Hi Definition Audio -" it's because you have no sound device installed. It looks like Windows is not detecting the RealTec sound device for some reason. That's why you can't install a driver, even if it's the correct one.

Take a look at this LINK. Go down to the bottom of the page and see if you can follow what he did to get sound working on his 21.5" iMac. Let me know if it works for you.

mellocakes 08-30-2010 03:14 AM

Quote:

I HAVE FOUND THE SOLUTION!!!!!!!!!!!!!!

What you do is:
1. Turn on your iMac and log onto windows.
2. Insert your Snow Leapord install disk.
3. Open My Computer, right click on the disk and click 'open'.
4. Navigate to \Boot Camp\Drivers\Cirrus and open 'CirrusAudioVista64.exe'.
5. Follow the installation process and restart your iMac when it tells you to.

Your sound should now work. It works for me on my 21.5" Late 2009 iMac.
I've also tried this but with no succes (I have the 32 bit version, btw)

Quote:

I was also facing the same problem with my iMac after installation of Windows 7 on it. To solve the problem, follow the steps below :-
Go to device manager in windows 7 and click on Sound device.
Remove the drivers which are installed for the sound device.
Insert the installation disk of snow leopard disc in the drive.
Right click on the drive and open it.
Now in the drivers section, select and install Vista64 drivers.
Let the procedure complete.
The first problem I have here is that there isn't anything as "sound device"...

pjhutch 08-30-2010 09:15 AM

Try downloading the latest Realtek (or Intel) HD drivers from the Realtek website to replace the old driver from Bootcamp. I had this problem last year with 10.5 and iMacs and the driver supplied installed ok but didn't work. I had to download a new driver.


All times are GMT -4. The time now is 02:22 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.