Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1

    ogacon's Avatar
    Member Since
    Mar 16, 2008
    Location
    Twin Cities (Suburbs) Minnesota
    Posts
    645
    Specs:
     15" 2.4 MBP  iPod Classic 80 GB, Silver
    Classic environment not supported?
    I tried installing star craft but it says it can't due to not supporting Classic Environment. Is there a way around this that is free and doesn't require to purchase an extra OS? Thanks! If I can't play SC I'll be disapointed
    Relay For Life Support me in Relay For Life! Run by American Cancer Society. Cancer research.
    What sound does your Rooster make?

  2. #2

    ogacon's Avatar
    Member Since
    Mar 16, 2008
    Location
    Twin Cities (Suburbs) Minnesota
    Posts
    645
    Specs:
     15" 2.4 MBP  iPod Classic 80 GB, Silver
    Well I think I found a solution, it's for starcraft though. So if others are having problems with a program I can't help ya there. But here is a link for the classic installer patch. I'll see if it works.
    http://ftp.blizzard.com/pub/starcraf..._Installer.dmg

    EDIT: I don't know if it installed it properly, or my SC is just lame cause my SC wont start
    Relay For Life Support me in Relay For Life! Run by American Cancer Society. Cancer research.
    What sound does your Rooster make?

  3. #3

    Chimpur's Avatar
    Member Since
    Jan 18, 2007
    Location
    Burlington
    Posts
    413
    Specs:
    See Signature
    Sheep shaver????

  4. #4

    ogacon's Avatar
    Member Since
    Mar 16, 2008
    Location
    Twin Cities (Suburbs) Minnesota
    Posts
    645
    Specs:
     15" 2.4 MBP  iPod Classic 80 GB, Silver
    but that requires a copy of the older os, which I don't have I was hoping for a solution to allow me to run it in OS X without having to reinstall. I have it installed I think, but evertime I try run it, it starts up like it;s about to go but then it just turns off. This sucks!
    Relay For Life Support me in Relay For Life! Run by American Cancer Society. Cancer research.
    What sound does your Rooster make?

  5. #5

    Soulwar's Avatar
    Member Since
    Jan 27, 2008
    Location
    Estero, FL
    Posts
    1,515
    Specs:
    iMac 17" 1Ghz G4  iPhone 3G  10.5.5
    Did you download the OSX "patch" for Starcraft? It will allow it to install thru OSX. Classic not needed or used.
    When all else fails, try everything!
    The Rep System and you.
    Life's a joke...If you're not laughing, then you didn't get it.

    June 2008


  6. #6

    ogacon's Avatar
    Member Since
    Mar 16, 2008
    Location
    Twin Cities (Suburbs) Minnesota
    Posts
    645
    Specs:
     15" 2.4 MBP  iPod Classic 80 GB, Silver
    I tried that. But when I get it installed, and after installing the latest patch, when I run "Sarcraft (Carbon)" a wraith bounces in my bar and then mouse moves to the same spot each time and then nothing happens.
    Relay For Life Support me in Relay For Life! Run by American Cancer Society. Cancer research.
    What sound does your Rooster make?

  7. #7

    Soulwar's Avatar
    Member Since
    Jan 27, 2008
    Location
    Estero, FL
    Posts
    1,515
    Specs:
    iMac 17" 1Ghz G4  iPhone 3G  10.5.5
    Special Note for OSX users: You can use our OSX native installer to install StarCraft on OSX.
    Run this then install.


    You post fast...
    When all else fails, try everything!
    The Rep System and you.
    Life's a joke...If you're not laughing, then you didn't get it.

    June 2008


  8. #8


    Member Since
    Mar 21, 2009
    Location
    Melbourne, Australia
    Posts
    1
    Specs:
    OS X Version 10.5.5
    I have another problem with this "classic environment", whatever it is.

    I'm trying to install the software associated with a secondhand CanoScan D660U colour image scanner and when I click on setup, I get the message: "Cannot open because classic environment is no longer supported."

    Can anyone help with this please? I'm not totally computer illiterate but I've never heard of a "classic environment" before.

  9. #9

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,934
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    Classic is the older Mac OS like Mac OS9 and before that OSX replaced. Very different than OSX which is BSD based. It's now called Classic. After Tiger 10.4, Apple changed 10.5 Leopard enough that there is no longer a Classic interface option. The only way I know a way around it is SheepShaver.

  10. #10


    Member Since
    Jan 19, 2010
    Posts
    2
    Hello everyone! I just purchased the classic version of Unreal Tournament for Mac. I also have a brand new Mac desktop, however when i tried to install the game on my Mac a message popped up that said it cannot install due to not supporting Classic Environment. How can i get this game to work?

  11. #11

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Location
    Texas, where else?
    Posts
    26,485
    Specs:
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    Check out the post right before yours.
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  12. #12


    Member Since
    Jan 19, 2010
    Posts
    2
    Do i install SheepShaver?

  13. #13

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    22,109
    Specs:
    Imac 27" Retina 5K, 512GB flash memory, 3.3GHz, 16GB memory, macOS Sierra beta.
    Like all emulators Sheeshaver is very, very slow. That is the price for forcing something to run in an environment it is not supposed to. Fior very, very slow consider VPC 6 as an equivalent:-

    MacBook Runs Hot, SheepShaver Feedback, Replacing Home Page, and Another PowerBook 1400 Fan

  14. #14


    Member Since
    Feb 25, 2010
    Posts
    481
    Specs:
    Mac Pro, Power Mac G4, iMac G3, iPhone 3GS
    If you want to run games designed for Mac OS 9 and before, it's at this point honestly easier and cheaper to get a used Mac. 500MHz G4s can be found for less than $50.

  15. #15


    Member Since
    Apr 02, 2010
    Posts
    14
    I'm perplexed. When installing, it asks for a 13-character cd-key. The cd-key on my disc envelope is one long 26-character cd-key. I tried inputting the first 13 and then the last 13; neither worked. Wtf?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Classic Environment Woes
    By GeorgeK in forum Running Windows (or anything else) on your Mac
    Replies: 5
    Last Post: 02-15-2011, 04:59 PM
  2. Classic environment?
    By flesheatingviru in forum OS X - Apps and Games
    Replies: 3
    Last Post: 10-14-2009, 10:01 PM
  3. Classic environment is no longer supported?
    By TomBone in forum Switcher Hangout
    Replies: 9
    Last Post: 10-09-2009, 05:29 AM
  4. Classic environment??
    By John C in forum OS X - Operating System
    Replies: 1
    Last Post: 07-15-2008, 11:03 PM
  5. classic environment?
    By djflair1 in forum Switcher Hangout
    Replies: 3
    Last Post: 01-27-2008, 01:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •