Results 1 to 2 of 2
  1. #1
    Bose Speaker Problem
    I have a set of Bose Companion 3 Speakers and it seem that the left channel port has a static sound too it. Ive swapped speaker to make sure of this and the speakers are fine, any suggestions? Im pretty sure my warrenty is up and if not I dont think they will replace them since they have been through a few blackouts. I also noticed that the static isnt relative to the volume no matter how high its turned up the static stays at the same level.

  2. #2
    Try cleaning the connectors/ports. This sometimes helps, as they can get greasy/etc. Other than that, no other suggestions, sorry

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Speaker problem?
    By Shanez in forum Apple Notebooks
    Replies: 0
    Last Post: 02-04-2012, 09:12 PM
  2. Speaker problem
    By HonestIllusion in forum Apple Notebooks
    Replies: 3
    Last Post: 06-16-2010, 02:13 AM
  3. Bose Companion 5 USB speaker problem
    By Sam_A in forum Other Hardware and Peripherals
    Replies: 6
    Last Post: 06-08-2008, 05:33 PM
  4. Speaker Problem
    By dpala1 in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 02-27-2008, 10:04 PM
  5. problem with speaker
    By mikimose in forum Music, Audio, and Podcasting
    Replies: 9
    Last Post: 06-11-2007, 06:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts