Results 1 to 8 of 8
  1. #1


    Member Since
    Jul 08, 2007
    Posts
    3
    external usb hard drive not being recognized
    I am experiencing some weird problem with my HITACHI 40G external USB HDD (FAT32)...It has been working for 2 years no problems on both Mac and PC. Haven't used it for 4 weeks as I sent my macbook to repair due to the random shut down problem. Now the device starts but it doesn't show up as a external device, i.e. I don't have access.

    Is it because of the new Software Update?

    Funny thing is I have 3 hard drives (External all using USB connection, 2x 3.5"desktop drive, and 1x 2.5" laptop drive, all formatted as FAT32) The 2 desktop drives work perfectly on my mac book pro however only the 2.5" HITACHI HDD does not work anymore. The light on the HDD was on when I plug it in and I can hear it running but just my lovely OS X does not wanna show it as a device in either Macintosh HD, desktop or disk utility.

    I still can't figure out why, because:
    - The two 3.5" ext. HDD work on my macbook pro, so it is not usb port problem as such.
    - The 2.5" ext HDD works on my colleague's macbook pro and my work pc (win xp), so it is not the ext. hard drive problem either!!

    I am confused, I am lost........

    What problem could it be????????????? It will be great if someone have any ideas of what weird thing is going on... Thanks Millions

  2. #2


    Member Since
    Jan 09, 2007
    Posts
    178
    Do you have OS 10.4.10?

    It is possible that it is because you have OS 10.4.10. Many people have been unable to use their USB hard drives since the update. It is very annoying and apparently still unfixed. I find it hard to accept that an apparently good company like Mac would leave so many of us with unusable hard disks for so long now. For us, the 10.4.10 update was just like receiving a virus!

    See this thread for example:
    http://www.mac-forums.com/forums/sho...d.php?t=67484&

    Justin
    Using brand new macbook

  3. #3


    Member Since
    Feb 18, 2007
    Posts
    265
    yup, 10.4.10 caused my external to stop mounting also. If you look around there's a solution involving taking a couple extensions from the 10.4.9 update. That worked for me.

  4. #4


    Member Since
    Jan 09, 2007
    Posts
    178
    Quote Originally Posted by visualpurple View Post
    yup, 10.4.10 caused my external to stop mounting also. If you look around there's a solution involving taking a couple extensions from the 10.4.9 update. That worked for me.
    Can you tell how to do it? Or post the link?
    Thanks
    Justin
    Using brand new macbook

  5. #5


    Member Since
    Feb 18, 2007
    Posts
    265
    Sorry, I don't have the link anymore... I found the instructions on macosxhints.com... so try a google search... it involved downloading 10.4.9 and using Pacifist to install 2 extensions from it, and using AppleJack to clear the cache... hope that helps you find it..

  6. #6


    Member Since
    Mar 28, 2008
    Location
    Inveracrgill New Zealand
    Posts
    1
    Angry Help USB still not mounting
    Hi all,

    I know this is slightly out of date post but has anyone found a solution for this?

    I believe I am experiencing the same problem with my Portable Media player which is essentially a 160GB HDD (Laptop one)

    I have tried many of the solutions offered arround the net to solve this issue. Here are my findings to date

    It mounts fine if I re-install the Mac OS X to 10.4.8 and don't do any further updates. If any further updates are done the device appears in the System Profiler but fails to mount on the desktop.

    I tried the Mac OS X 10.4.9 for iTunes 7.6 to work, then it stops mounting again.

    The 10.4.10 USB Update found here still doesn't allow my portable hard drive to mount.
    http://www.apple.com/support/downloa...ev11intel.html

    I am nbot too sure on these other solutions as they muck around with the kernel etc but they may help others
    http://www.macosxhints.com/article.p...y=10.4.9%2BUSB

    This is very frustrating! I have tried for months on and off to find a solution for this. The drive works fine on a Power PC G5, any Windows machine but fails to work on any iMac that has 10.4.10. Is there another solution?

  7. #7


    Member Since
    Mar 04, 2009
    Posts
    3
    *sigh* I'm experiencing a similar problem with my Toshiba portable HD

  8. #8

    vansmith's Avatar
    Member Since
    Oct 19, 2008
    Location
    Toronto
    Posts
    19,743
    Specs:
    2012 13" MBP (2.5 i5, 8GB)
    Have you guys tried upgrading to 10.4.11? I notice all of you stop at 10.4.10.
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. External hard drive not recognized
    By cas3704 in forum Apple Notebooks
    Replies: 11
    Last Post: 04-01-2014, 11:09 PM
  2. External Hard Drive - not recognized
    By yechialo in forum OS X - Operating System
    Replies: 2
    Last Post: 12-23-2013, 01:27 PM
  3. External USB Drive No Longer Recognized
    By shacho in forum Apple Desktops
    Replies: 0
    Last Post: 06-14-2009, 03:47 AM
  4. USB Hard Drive not recognized
    By CPUFreak91 in forum Apple Notebooks
    Replies: 1
    Last Post: 03-05-2008, 06:47 PM
  5. Replies: 2
    Last Post: 02-10-2006, 10:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •