Results 1 to 2 of 2
  1. #1

    Member Since
    Jun 11, 2007
    Exclamation Western Digital My Book mounting problem

    I just bought this Western Digital My Book 320Gb with usb2.0 and FW400 ports. I plug it with usb and it works fine. When i try to use just firewire, and it dose not appear on the desktop, also the Mac os is not even recognizing this drive. I can identify whether the problem is my fw or the dirve itself. Btw, im using the 2.16ghz macbook. I hope someone can help me solve this problem, so i dont have to return this.

    Thank you for you help~!

  2. #2

    Member Since
    Feb 16, 2007
    No way of telling which Firewire is broken, the MB or the MyBook's.

    Just return it for another unit.

    The FW800 on mine works, FWIW.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Western Digital My Book Essential 3TB external
    By spindoctor69 in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 01-20-2012, 08:43 AM
  2. Western Digital My Book Premium Edition keeps going to sleep
    By spacecadet1968 in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 04-12-2010, 10:18 PM
  3. Western Digital My Book External Hard Drive 1 TB - Any Feedback?
    By davedave in forum Other Hardware and Peripherals
    Replies: 6
    Last Post: 09-28-2008, 03:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts