New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

G4 Problems


Post Reply New Thread Subscribe

 
Thread Tools
elmyr
Guest
 
Posts: n/a

When I attempt to switch on my G4, the light briefly glows and then goes out. It just won't start up. Anyone have any idea how to fix this - or what the problem might be?

Many thanks
E
QUOTE Thanks
rman

 
rman's Avatar
 
Member Since: Dec 24, 2002
Location: Los Angeles, California
Posts: 12,591
rman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud of
Mac Specs: 2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi

rman is offline
How old is the G4?

Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!
QUOTE Thanks
Chamorro
Guest
 
Posts: n/a

Perhaps the PRAM battery is dead, or there is a loose internal connection somwhere (have you done anything inside your computer recently?). More serious issues could be a dead HD and/or dying power supply.
QUOTE Thanks
rman

 
rman's Avatar
 
Member Since: Dec 24, 2002
Location: Los Angeles, California
Posts: 12,591
rman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud of
Mac Specs: 2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi

rman is offline
That is where I was going with the age of the computer.

Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!
QUOTE Thanks

Post Reply New Thread Subscribe


« New eMac - what should I get? | I just got one!!! »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
OSX SCSI & scanner recognition problems mr.brien OS X - Operating System 0 02-24-2004 11:25 AM
HELP! New G4 emac- problems uploading and sending attachments braford Other Hardware and Peripherals 0 02-13-2004 03:19 PM
help: my G5 is having some major starting up problems h3o Apple Desktops 12 01-10-2004 01:25 AM
gif animation problems in Entourage via email totalbuddy Schweb's Lounge 0 12-18-2003 05:44 PM

All times are GMT -4. The time now is 02:04 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?