Results 1 to 3 of 3

Thread: External Doesn't Mount Sometimes

  1. #1

    Member Since
    Jan 22, 2007
    External Doesn't Mount Sometimes
    So I purchased a 500GB Seagate SATA hard drive that I put in an AMS Venus USB 2.0 external enclosure recently and while it has been working fine for the most part, occasionally it decides not to mount. This happened once a few months ago when I first got the drive. I remember I started copying some files from my other external drive but stopped it so I could plug the drive into a surge protector and when I turned the 500GB drive back on it wouldn't mount.

    After some time (maybe a day or so) OS X recognized the drive and it had been working fine, until yesterday that is.

    After copying some songs from my 500GB drive to my iPod and restarting my computer, the external would not mount (Tried removing the iPod, switching USB ports, turning off anything else that was plugged into the same surge protector as my drive). Tried booting into windows via bootcamp to see if the drive would show up (I have a 65.75 FAT 32 partition on the drive) but alas, nothing.

    I just turned my computer on a minute ago and miraculously everything works fine again, but I have no idea why this drive decides not to mount sometimes.

    The drive model is ST350064
    and I am using this enclosure

    Any help would be greatly appeciated

  2. #2

    mac57's Avatar
    Member Since
    Apr 29, 2006
    St. Somewhere
    Does this happen with any other external drives you have used? You have a tough problem there - hard to tell whether it is the drive, the Mac or the combination of the two.
    My Macs: iMac 27" 3.4 GHz, Mac Pro 3.2 GHz, PowerMac G5 Quad 2.5 GHz, G4 Cube with 1.2 GHz Upgrade
    My iStuff: 64GB iPhone 5, 64GB iPad4, 30GB iPod Video, 16GB iPod Touch
    My OS': Mac OS X Lion, Mac OS X Snow Leopard, Mac OS X Tiger, Mac OS 9.2.2, openSUSE 10.3
    I was on the Mac-Forums honor roll for September 2007

  3. #3

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Texas, where else?
    Could be the Mac, the cable, the drive or the enclosure. Easiest one to rule out is the cable. The other 3 will be pretty tough unless you have a spare hard drive and enclosure laying around.
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. USB drive doesn't mount! (MacOSX/Windows)
    By karapetyan in forum macOS - Operating System
    Replies: 8
    Last Post: 02-23-2015, 02:55 PM
  2. Script to mount volume (external drive or disk image) which won't mount..?
    By MaccIngs in forum macOS - Development and Darwin
    Replies: 2
    Last Post: 09-09-2011, 09:05 PM
  3. External Hardrive was working and now doesn't mount
    By domarisdione in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 09-05-2010, 10:07 PM
  4. When an iso doesn't mount?
    By Splint in forum Switcher Hangout
    Replies: 2
    Last Post: 06-27-2010, 12:15 PM
  5. external HD doesn´t mount
    By rafaelpinheiro1 in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 11-29-2008, 11:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts