Results 1 to 2 of 2

Thread: mx700 problems

  1. #1
    mx700 problems
    I recently bought an mx700 and it's a great mouse but there is one problem. The base station does not indicate that the mouse is charging (green LED should blink) and I've been using other rechargeable NIMH batteries in my own recharger, but the whole reason I got this mouse is so I wouldn't have to continuously recharge these batteries and that the base station would do it for me. Anybody else with this mouse experience these same problems?

    Thanks for the help guys!

  2. #2
    i have mx700 also, but never experienced any problems in charging the mouse... that's not normal, i think, and you should take it back to the store if possible. mine had a warranty of one year, but i have no clue if it is different in other countries...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Airport Connection Problems as well as Mac Apps Problems
    By kdubs2691 in forum Apple Notebooks
    Replies: 5
    Last Post: 07-25-2009, 02:22 PM
  2. Time Machine Backup Problems - mounting problems
    By bagpuss1974 in forum OS X - Operating System
    Replies: 0
    Last Post: 06-23-2009, 10:37 AM
  3. Mac Book and Canon MX700
    By adelerach in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 11-24-2008, 09:11 PM
  4. Realtek sound problems, lag problems
    By Starflame in forum Running Windows (or anything else) on your Mac
    Replies: 2
    Last Post: 11-08-2008, 11:54 AM
  5. more memory problems and date problems with usb
    By jsnow in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 01-04-2007, 04:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts