New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

Creature II help


Post Reply New Thread Subscribe

 
Thread Tools
x59

 
Member Since: Dec 29, 2004
Posts: 51
x59 is on a distinguished road
Mac Specs: 13.3" Aluminum Macbook 2.0gHz, 2 gHz 20" Core Duo iMac.

x59 is offline
I recently purchased a set of Creature II speakers off of ebay, but directly from Harman Audio. Refurbished. I plugged them in, they worked great. LED's were on on the satellites and the woofer. Came home from work and the satellites are not working. LED is on on the woofer, all the cables are in place and plugged and unplugged many times to secure connection. Nothing. If anyone has some insight, please let me know.
QUOTE Thanks

Post Reply New Thread Subscribe


« Installing an External DVD Burner | External Hard Drive Won't Mount »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
not a creature was stirring... eric Schweb's Lounge 5 12-07-2006 09:04 PM
iMac internal speakers vs. JBL Creature II iMacTravis Apple Desktops 7 12-11-2005 05:30 AM
Creature Speakers pphking Apple Desktops 2 11-29-2005 12:26 PM
creature II problems? likewings Other Hardware and Peripherals 1 03-19-2005 06:01 PM
white creature liverpool-lad Archival Forum 5 05-24-2004 09:43 AM

All times are GMT -4. The time now is 02:15 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?