New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

Samsung ml2510 printing problems


Post Reply New Thread Subscribe

 
Thread Tools
kforum

 
Member Since: Jul 24, 2006
Posts: 14
kforum is an unknown at this point

kforum is offline
Need help,

My intel Imac will not print. I bought a new Samsung ml2510 printer. it will print a test sheet fine. therefore the printer is working. I have installed the mac driver, and a "Samsung smart panel". When I print it says that the printer is "stopped" and that the job would/could be added to the que depending upon if i pick conitnue or add to que. There is an "!" behind the printer.

In short, how do i get this thing to print???????????????????
QUOTE Thanks
jtnkelly

 
Member Since: Dec 23, 2006
Posts: 16
jtnkelly is on a distinguished road

jtnkelly is offline
I purchased the same printer yesterday and had the same EXACT problem: everything was there, but it would not print.

Solution: Repair Permissions fixed the problem for me. Don't know why, but it worked.
QUOTE Thanks
mkaprelian

 
Member Since: Jan 03, 2007
Posts: 2
mkaprelian is on a distinguished road

mkaprelian is offline
Same problem here with new Intel Core2Duo iMac. Driver on printer's install CD did not work. Downloading newest driver from Samsung's web site did not help. Repairing permissions did not help.

I had seen something somewhere about older drivers for other Samsung printers working. But I'd be grateful for a better solution.
QUOTE Thanks
Eloth

 
Member Since: Jan 03, 2007
Posts: 4
Eloth is on a distinguished road

Eloth is offline
I have a powerbook G4 and am having the same exact problem. Anyone know how to fix this!?
QUOTE Thanks
mkaprelian

 
Member Since: Jan 03, 2007
Posts: 2
mkaprelian is on a distinguished road

mkaprelian is offline
I found several useful discussion forums on apple.com site. Ultimately, I found a useable driver on Samsung's UK site.
QUOTE Thanks
phaedon

 
Member Since: Jan 15, 2007
Posts: 1
phaedon is on a distinguished road

phaedon is offline
run spl2 installer

then go to system preferences > print and fax

delete the ml-2510 by clicking the minus square

click the add square..

select the ml-2510 again, and make sure that at the bottom of this window, under the "Print Using:" field, you again select the ml-2510.

click add.

print a test page. you will notice the printer works and the smart panel thingie at the top of your window also works
QUOTE Thanks
drbrookes

 
Member Since: Jan 04, 2008
Posts: 1
drbrookes is on a distinguished road

drbrookes is offline
Thanks so much - this was terribly annoying. Deleting and re-adding the printer and changing the setting as you suggested solves the problem for me. I am using an Intel iMac with OSX.
QUOTE Thanks
Aziesl

 
Member Since: May 15, 2008
Posts: 2
Aziesl is on a distinguished road

Aziesl is offline
Quote:
Originally Posted by kforum View Post
Need help,

My intel Imac will not print. I bought a new Samsung ml2510 printer. it will print a test sheet fine. therefore the printer is working. I have installed the mac driver, and a "Samsung smart panel". When I print it says that the printer is "stopped" and that the job would/could be added to the que depending upon if i pick conitnue or add to que. There is an "!" behind the printer.

In short, how do i get this thing to print???????????????????
Please can you help
QUOTE Thanks
Aziesl

 
Member Since: May 15, 2008
Posts: 2
Aziesl is on a distinguished road

Aziesl is offline
Quote:
Originally Posted by phaedon View Post
run spl2 installer

then go to system preferences > print and fax

delete the ml-2510 by clicking the minus square

click the add square..

select the ml-2510 again, and make sure that at the bottom of this window, under the "Print Using:" field, you again select the ml-2510.

click add.

print a test page. you will notice the printer works and the smart panel thingie at the top of your window also works
Thank you it work ur a STAR
QUOTE Thanks
SiliconBear

 
Member Since: Oct 03, 2008
Posts: 1
SiliconBear is on a distinguished road

SiliconBear is offline
I feel the printing quality with Mac is worse than with PC, although official Samsung drivers are used in both cases. Did you notice that?

Also some PDF files do not print, and I have to force the acroread to print them as image. This automatically leads to very poor quality.
QUOTE Thanks
AdamIMac

 
Member Since: Mar 02, 2010
Location: Oregon
Posts: 1
AdamIMac is on a distinguished road
Mac Specs: IMac9,1 OSX v. 10.5.8; 2.66 GHz Intel Core 2 Duo; 4GB 1067 MHz DDR3

AdamIMac is offline
Quote:
Originally Posted by phaedon View Post
run spl2 installer

then go to system preferences > print and fax

delete the ml-2510 by clicking the minus square

click the add square..

select the ml-2510 again, and make sure that at the bottom of this window, under the "Print Using:" field, you again select the ml-2510.

click add.

print a test page. you will notice the printer works and the smart panel thingie at the top of your window also works
Thank You!!! That worked.
QUOTE Thanks
Howtodo

 
Member Since: Jan 03, 2012
Posts: 3
Howtodo is on a distinguished road

Howtodo is offline
Quote:
Originally Posted by AdamIMac View Post
Thank You!!! That worked.
I have Ml2510 for a few years and worked fine.
Yesterday I printed out one page doc.
When I tried to print another it has the same problem as mentioned here.
I did remove and add etc. It didn't work. Help
QUOTE Thanks
Howtodo

 
Member Since: Jan 03, 2012
Posts: 3
Howtodo is on a distinguished road

Howtodo is offline
I fixed the problem. If anyone still has same problem, please try:
Go to finder -- mac HD -- Library -- Printer -- Lexmark folder.
Copy it to your own storage area then delete the folder. Down load ML2510 driver.
Uninstall ML2510 then install again. After installation go to system reference
select printer-fax -- click last printer used "make sure ML2510" make sure it is there.
Click [-] to remove then click [+] to add ML2510 back.
QUOTE Thanks

Post Reply New Thread Subscribe


« Verizon G4 MIFI and IMAC G5 | What would this be able to do.. »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Printing Problems luigihip Images, Graphic Design, and Digital Photography 3 10-12-2006 12:04 PM
Switcher with printing problems. helto Switcher Hangout 3 09-02-2006 09:18 AM
Problems Printing Wirelessly To Printer From Pc Using Airport Express maria Internet, Networking, and Wireless 3 05-16-2006 10:47 PM
Cube problems with printing wendz Apple Desktops 7 04-14-2005 09:56 PM
InDesign 2.0 Color Printing Problems kryana OS X - Operating System 4 02-17-2005 02:26 PM

All times are GMT -4. The time now is 09:47 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?