how can i get canon mp500 working with my NETGEAR SP121 print server. i have multiple PCs that are printing through it and my macs can print to it as well but due to (my thought is dirver issues) the macs dont print properly. I have downloaded the most recent drivers for my mac and still nothing.

**the machines are hookedup through 2 switchs that are then hookedup to my schools network**
(the school does allow printer sharing and i know this is not theproblem, as you can see when you read on) (one PC on one switch works and the other PC o the other switch works so this also is not the issue)

When i go to the add printer etc etc type in my IP queue name LPT1 but can only choose the defualt apple drivers that are old as. if i select the BJ30 everything prints condensed. if i select an S model the text prints fine but the pics are all distorted select the ip4000 it wont print at all. so my conclusion is im soooo close but the driver is preventing me.

netgear i cant deal with cause they are outsourced and ask for the most absurd info from me which i cant get due to me not being in control of my university i dont think it has anyting to do wiht the print server do to the fact the PCs print fine.

canon says that model is not network compat so there tech support wont help. I know this is not true cause my PCs print fine from it.

i have heard things about gutenprint. ghostprint. cups. unix all these things i know by name but have not the slightest clue on how/wherei would set these thingsup or if they will even work.

to my knowledge there is not one thing on the interent that i can find with my problem, its either linux and my printer or mac os x and the mp 800, or the netgear and a samsung, or the mp500 and the airport. never my exact setup so any proposalls would be GREATLY appreicated cause i am at my demise with this.

i have found places deep into my harddrive that look promising such as driver flolders, canon net utilities but nothing seems to work or i might not be hitting the correct buttons