I have a 12" Al G4 PowerBook running 1.33ghz and 1.25gb ram w/ 80gb hdd.

About two years ago I purchased a Cruzer Micro 512mb. I love everything about this drive (size, construction, price and capacity) EXCEPT for the fact that I cannot get it to work on my PowerBook!! It works on many other computers (PCs and Macs) that I've tried it on, but for some reason the only way I can get my computer to mount it is if I first plug it into an old USB 1.1 hub that I have.

I've tried EVERYTHING. I've reformated/repaired it in Disk Utility, and gone to several people (except for the genius bar) for help and every time it's come up still not working. I've even tried reformating my laptop and it still doesn't work.

First of all, is there any explanation for this?
Second, is there any way to fix it?

It's possible that this was a problem in the product two years ago and has since been remedied (SanDisk's consumer help was NOT HELPFUL and the guy that I talked to was a complete and utter ***). My roommate wants to buy the drive from me, and I would like to get a 1gb flash drive, but I would really like to get another micro, because I like them a lot. So...

Third, has this issue been fixed? Do any of you have this drive and it works?

Fourth, if no to all of these, do you have a similar drive that you would recommend?

Thanks for the advice.