Results 1 to 4 of 4
  1. #1
    Unhappy external firewire HD wont mount!
    last night, i noticed that one of my external firewire hard drives was not detected on the desktop or finder. at first i thought it was a panther issue, but noticed the drive not being detected within my classic mode. right now, i am sitting at work in front of one of our G3 machines runnnig os9 and the drive is still not mounting.

    i should also mention that i have run Disk Warrior and Techtool Pro last night hoping to resolve this issue. however, i was not able to fix anything because the drive was not being detected by my computer.

    at the moment, the hard drive is starting to make clicking noises and inconsistent whirring noises too. this machine cannot detect the hard drive at all, and i have ruled out that it is a firewire cable issue.

    the hard drive i have is an Ezquest Cobra firewire 80gig drive. i have run all the latest firmware updates so that it is all compliant with Panther. but, this problem seems to go beyond the operating system and persists on different machines and operating systems.

    please help me! i have a lot of valuable data on here that i would like to salvage if i can. if not, i am willing to live with that. as long as i have a working external hard drive again. excuse me while i go cry now... help me


  2. #2

    Member Since
    Jul 22, 2003
    Hamilton College
    20" iMac C2D 2.16ghz, 13" MacBook 2.0ghz, 60gb iPod vid, 1gb nano
    hard drives clicking is a very bad thing. the drive itself could be dieing.

  3. #3
    is there a way for me to force mount the hard drive so that i can test, remedy and/or format the drive using Disk Warrior or Techtool Pro?

  4. #4
    What kind of firewire dirve?

    I had the same problem, with the Oxford 200 firewire drive. Later I learned the G4 400 CPU does really want to recognize 200 Gig HD, even though I was running Panther, I installed OS 9 in the backround to mount the drive. Also with a big drive like that you should partition it. Now it is mounting. Go figure. Hope this helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Failed to mount External HDD using FireWire but OK using USB
    By sshark in forum Other Hardware and Peripherals
    Replies: 11
    Last Post: 04-15-2010, 04:05 AM
  2. External hard drives wont mount
    By vnote in forum Other Hardware and Peripherals
    Replies: 9
    Last Post: 08-15-2009, 02:32 AM
  3. External HDD wont mount
    By MBasile in forum Other Hardware and Peripherals
    Replies: 6
    Last Post: 05-18-2008, 04:36 PM
  4. External Hard drive wont mount
    By andrewthegreat in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 05-23-2007, 07:47 PM
  5. Maxtor External Firewire HD won't mount
    By jordan2 in forum Apple Desktops
    Replies: 6
    Last Post: 10-09-2006, 11:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts