I've been successfully working with a Western Digital External Firewire 200 GB Hard Drive for over 2 years on both my Powerbook G3 Pismo (Panther) and iBook G4 (Tiger).

However, last night, due to moving the hard drive (and possibly a loose power cord), I improperly disconnected the HD from the iBook. Since then, I haven't been able to mount the HD. And now, I can hear a series of slow clicks... like it's searching the HD and not finding anything.

After resolving to lose all my data, I decided to erase and start fresh. Now, I can't erase, partition, or even create a new image.

Here's what the Disk Utility Info Says:

Name : WDC
Type : Disk

Disk Identifier : disk1
Media Name : WDC FireWire HDD Media
Media Type : Generic
Connection Bus : FireWire
Connection Type : External
Connection ID : 40718557708812971
Device Tree : fw/node@90a950000002ab/sbp-2@4008/@0:0
Writable : Yes
Ejectable : Yes
Mac OS 9 Drivers Installed : No
Location : External
Total Capacity : 2.0 TB (2,199,023,255,552 Bytes)
S.M.A.R.T. Status : Not Supported
Disk Number : 1
Partition Number : 0

Here's what the System Profiler says:

FireWire Bus:

Maximum Speed: Up to 400 Mb/sec

FireWire HDD:

Manufacturer: WDC
Model: 0x0
GUID: 0x90A950000002AB
Maximum Speed: Up to 400 Mb/sec
Connection Speed: Up to 400 Mb/sec
FireWire HDD Unit:
Unit Software Version: 0x10483
Unit Spec ID: 0x609E
Firmware Revision: 0x411
Product Revision Level: 4.11
Capacity: 2 TB
Removable Media: Yes
BSD Name: disk1
OS9 Drivers: No
S.M.A.R.T. status: Not Supported

When I attempt to partition, erase, or create a new image... an Input/Output Error notice pops up.

I'm at a COMPLETE LOSS! On the bright side... it looks like that I now have a "2 TB" capacity external HD!!! WOW!!!!

Any advice/suggestions are greatly appreciated in advance.