New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

Cannot Connect Epson 435 to Mac OS X 10.9.4


Post Reply New Thread Subscribe

 
Thread Tools
kaijastaley

 
Member Since: Jul 20, 2014
Posts: 3
kaijastaley is on a distinguished road

kaijastaley is offline
I cannot wirelessly connect my Epson printer to my Mac. I have checked all of my connections and have updated software, but I cannot print without the USB cord attached. Any advice? I'm getting frustrated after installing and uninstalling my printer and turning my router on and off a million times. Thanks.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 40,948
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, Yosemite

chscag is offline
Did you follow Epson's instructions for setting it up for wireless printing? I'm not going to re-iterate them here but what you'll wind up with is two instances of the Epson 435 in System Preferences, Printers & Scanners. One will be for connecting via USB, the other will be wireless.
QUOTE Thanks
gsahli

 
Member Since: Dec 11, 2010
Posts: 1,129
gsahli is a jewel in the roughgsahli is a jewel in the roughgsahli is a jewel in the rough

gsahli is offline
What's the actual model number? PX435 or workforce 435?

Hope you aren't installing software directly. The current driver for those two models is available for auto-download in OS X, when you add the printer in Print & Scan prefs. Maybe you need to delete the /Library/Printers/Epson folder and try adding again. Or, reset printing system before re-adding:
OS X Mavericks: Reset the printing system
QUOTE Thanks

Post Reply New Thread Subscribe


« using history on macbook pro | Control Keys stopped working »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Running Windows on a Mac: A Switcher's Guide cwa107 Running Windows (or anything else) on your Mac 290 09-18-2014 03:51 PM
General Security Tips for your Mac vansmith Security Awareness 20 09-13-2014 08:48 AM
Export Outlook for Mac Data and Import in Mac Mail L12-George OS X - Operating System 4 07-16-2014 06:42 AM
Connecting your Mac to your TV bobtomay Other Hardware and Peripherals 723 07-07-2014 08:30 AM
Unable to connect my old Mac hard drive (as external HD) to new Mavericks mac hopper8 OS X - Operating System 5 06-14-2014 11:41 AM

All times are GMT -4. The time now is 11:04 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?