Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Other Hardware and Peripherals (http://www.mac-forums.com/forums/other-hardware-peripherals/)
-   -   Maxtor external HD not mounting HELP!!!! (http://www.mac-forums.com/forums/other-hardware-peripherals/31059-maxtor-external-hd-not-mounting-help.html)

AnatomyOfARyan 02-21-2006 08:55 PM

Maxtor external HD not mounting HELP!!!!
 
ive got a maxtor 3100 80 gig USB 2.0 external HD. ive had it for 6 months now, never had any problems with it... until yesterday....

it wont mount to my HD. ive tried to reset it over and over, and the lights are going on like its booting up... just never mounts to my desktop. i searched a little in the forums to see if anyone else was having this problem, and they recommended going to disc utility and try to run the first aid on it. i did so, and i keep getting error messages. it is showing up that its plugged in, but isnt usuable. is this thing shot?

i hope not... but if it is, what are my options? ive got quite a bit of stuff on this HD and really hate to lose it. my warranty is done on it, and i really want the stuff on it more than the HD. any help? thanks in advance.

osvoldk 02-22-2006 02:03 AM

Well, I have had the same problem with Maxtor and being compatible with mac. You will need to qualify what is happening, that will be the only way I can help you out. First, are you using this external harddrive with any other operating systems? Second, when you unplug the harddrive from the computer, do you receive the disk removal error? Thirdly, did you attempt or succeed in formatting it before you had problems. Fourthly, do you have any other operating systems or computers that will reconize the drive. This will give a good start. If you could write me an email at osvoldk@mac.com I am sure that I can help you out


All times are GMT -4. The time now is 09:19 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.