I'm not sure if this is a Mac problem or a network connection problem. Since last week my documents won't print in tabloid settings. Never had a problem before and this started randomly. I'm using a 2010 (spring) Macbook running Mountain Lion and wirelessly connected to my work's Oki C830. I've tried printing from various programs: Illustrator (original .ai file and PDF), Preview and Acrobat.

All have definitely been set to tabloid and even correctly showed up in the print preview. But then the document prints in 8.5 x 11, but not shrunken down. The printer area cuts off as if it's printing tabloid size but just on standard letter format. No one else at work has this problem. I can print 8.5 x 11 documents just fine, it's only when I try to print in tabloid. I've tried deleting the printer and reinstalling, resetting my print settings from System Preferences, downloading/installing the printer driver.

My co-worker said this happened to him on his MacBook Pro and that it just "randomly" started working months later. Any ideas on what could be causing this?