Results 1 to 3 of 3
  1. #1

    Member Since
    Sep 03, 2007
    Lacie EXT HD spins but doesnt mount
    I have a Old Lacie (FA PORSCHE DESIGN) ext hard drive which no longer mounts. I can hear it spinning. It connects to my older Mac thru firewire (old 400 port i believe it is)

    Is there anything I can do to salvage whats on the drive? Ive popped it open and its a MAXTOR 160GB ATA/133 HDD 3.5 series. Is it possible the box is shot but the drive can be put into another case and if so where do you get empty cases for HDs from?

    Any help is greatly appreciated

    Cheers Mike

  2. #2

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    27" iMac i7 (2011) 10.11, Mac Mini i5 (2014), iPhone6s, Apple Watch, iPad Air 2, New AppleTV (4?)
    It could be the drive or the enclosure.

    If you post bac with which country you're in I can point you in the direction of a replacement.
    Not been around these parts for a while. Trying to change that . .

    Please use the reputation system if you think you've been helped - bottom left of this post

  3. #3

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Texas, where else?
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    You could get a IDE / SATA to USB adapter kit also - be able to connect any bare drive via a USB port - invaluable tool. Here's one i found at an Aussie site - link. Don't know anything about that site, but that gives you an idea what you're looking for.
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lacie or Wd ext. Hd
    By spanky in forum Switcher Hangout
    Replies: 0
    Last Post: 08-07-2008, 08:23 PM
  2. Lacie 320gb Ext Hd - Not Mounting
    By iddy78 in forum Other Hardware and Peripherals
    Replies: 5
    Last Post: 01-30-2008, 11:50 PM
  3. Network Drive doesnt mount, please help!!!
    By markyeungcy in forum Internet, Networking, and Wireless
    Replies: 7
    Last Post: 12-05-2007, 08:22 PM
  4. Lacie 2d ext hdd question
    By tylerboyo in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 12-31-2006, 12:59 AM
  5. External USB Lacie HD doesnt work....
    By ldj in forum Apple Notebooks
    Replies: 0
    Last Post: 10-21-2004, 04:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts