Results 1 to 5 of 5
  1. #1

    Member Since
    Dec 01, 2009
    Can't print PDFs
    I'm using a MacBook pro and at my work I print to a Sharp MX-3100N copier. I recently upgraded to OSX Lion and now for some reason I can't print PDFs. Word documents still print just fine.

    I tried reinstalling the driver for the copier but it didn't fix the issue. Any ideas?

  2. #2

    XJ-linux's Avatar
    Member Since
    Jul 02, 2007
    Going Galt...
    Try adding the printer again (keeping the original one), but give it a different name and let the Mac decide what to do with configuration. Sometimes downloading a driver messes everything up. You could also try adding it manually in CUPS. In a browser address bar type:

    You may need to run from the command line:
    cupsctl WebInterface=yes see the CUPS interface. From there just click the Administration Tab along the top of the page. It's fairly simple to follow the included directions to add a printer.
    Never judge a man, untill you have walked a mile in his shoes...
    That way you'll be a mile away from him, and you'll have his shoes.

  3. #3

    Member Since
    Dec 01, 2009
    I tried adding the printer again and it didn't solve the problem. I then deleted both the original printer and the one I added, restarted and then added the printer again. Still no luck.

    I guess I'm not computer savvy enough to figure out the CUPS interface. How do you use that? I typed "localhost:631" in the browser and it said that the web interface is disabled. How do I get to the command line to to enable it?

    Also, to clarify, I can print documents, spreadsheets, even web pages, but I can't print anything from Preview. It also appears that I can't print emails (from Mail or Thunderbird).

  4. #4

    Member Since
    Dec 01, 2009
    Also, for further clarification, I have now updated from Lion to Mountain Lion and I'm still experiencing the same issue.

  5. #5

    Member Since
    Dec 01, 2009
    And now that I've run the latest Mountain Lion update (now running 10.8.1), I can't print to this copier at all! I can, however, print to a different printer in the office with no limitations. So it has to be a driver issue with this particular copier. Sharp's website only has Mac drivers for up to OS X 10.7 for the copier.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PDFs print different colour
    By iWheeler in forum Images, Graphic Design, and Digital Photography
    Replies: 1
    Last Post: 05-27-2015, 12:08 PM
  2. Automator print PDF plugin - email and THEN print?
    By zenislev in forum OS X - Apps and Games
    Replies: 0
    Last Post: 11-21-2012, 10:24 AM
  3. Print PDFs with Applescript
    By jonkovach in forum OS X - Operating System
    Replies: 2
    Last Post: 09-30-2009, 11:05 AM
  4. How to view and print quality photos on a Mac via email, internet or print
    By PastorP in forum Images, Graphic Design, and Digital Photography
    Replies: 0
    Last Post: 04-23-2009, 10:48 AM
  5. Looking for a good program like Print Master/Print Shop
    By markw10 in forum OS X - Apps and Games
    Replies: 3
    Last Post: 04-09-2007, 12:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts