Results 1 to 6 of 6
  1. #1

    Member Since
    May 20, 2012
    Hard drive not mounting
    My Macbook Pro was running absolutely fine until I tried transferring a 10GB file from an external disk drive. It froze 3 times and each time I had to switch the power off on my machine to restart (it's at this point I gave up trying to transfer but I wish I'd given up earlier!)

    Shortly after my machine started freezing, and after this happening about 3 times my machine won't get past the grey apple logo/spinning wheel.

    I've tried booting from my Snow Leopard CD and Disk Utility found no problems, so I decided to try reinstalling Snow Leopard - it began working and then stopped, saying it couldn't install and no longer showing my hard disk. Since then I can't get the hard disk to show as a disk in Disk Utility...

    Any ideas? Any help much appreciated.

    I can hear the disk spinning as it tries to boot but it's still just sitting on the grey apple logo screen...

  2. #2

    Slydude's Avatar
    Member Since
    Nov 15, 2009
    North Louisiana, USA
    2.8 GHz MacBook Pro 10.10.2, 8 GB mem, iPhone 6+
    It sounds like the drive may be failing or has failed. I am not sure if this will work but you can try the following:
    1. Turn the power on on your Mac.
    2. Immediately after the startup chime (bong) press the command and s keys simultaneously.
    3. A text screen will start scrolling. When it stops tip fsck -fy and press enter.

    Your Mac will check the hard drive similar to they way it did in Disk Utility. If it reports the volume is OK try to reboot the Mac. If errors are reported that were not repaired try running the fsck command again.
    Sylvester Roque Former Contributing Editor About This Particular Macintosh

    "Got Time to breathe. You got time for music." Denver Pyle as Briscoe Darling

  3. #3

    Member Since
    May 20, 2012
    Thanks - tried that and it said the disk was fine, I then tried to exit and it came up with an error and then suddenly came up with lots of lines repeated:

    disk0s2: media is not present.

    Restarted and tried again and said "Root device is mounted read-only" then after that "the volume appears to be OK"

    After I try to exit it comes up with "Cannot get audit control port. Warning: audit system low <5% free" (there's about 10GB space left on my hard drive)

    Then it comes back with diskos2: media is not present again...

  4. #4

    Member Since
    May 20, 2012
    I've tried reinstalling OSX again from the CD and the same thing has happened - it starts installing and when it gets to about 20% it says it doesn't have enough memory, then shows what it's trying to install on and it's the below - the hard drive seems to have vanished after showing before...screengrab attached.

  5. #5

    Member Since
    May 20, 2012
    Apologies for bumping this but the issue is still happening - it seemed like it was better for a while but now it's back to crashing all the time...any ideas?

  6. #6

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Even though the file system check stated the hard drive is OK, I suspect the drive may be failing. The file system check, both the command line version and the Disk Utility version, can only check the integrity of the file and folder system. It does not check the hardware or drive electronics.

    You may have to replace the drive.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. External hard drive not mounting.
    By sandnsurf in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 05-03-2010, 05:09 AM
  2. Mounting an External Hard Drive
    By cranfordrw in forum Switcher Hangout
    Replies: 5
    Last Post: 02-06-2010, 02:45 PM
  3. Mounting External Hard Drive
    By grp318 in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 09-16-2008, 06:09 PM
  4. External Hard Drive not mounting
    By Ben5504 in forum Apple Notebooks
    Replies: 0
    Last Post: 08-29-2007, 12:51 AM
  5. Hard drive not mounting
    By uncletoe in forum Apple Desktops
    Replies: 2
    Last Post: 09-05-2006, 10:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts