New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

External Hard Drive Won't Mount on Desktop (2 years-no fix yet))


Post Reply New Thread Subscribe

 
Thread Tools
slhcvltd

 
Member Since: Aug 25, 2010
Posts: 6
slhcvltd is on a distinguished road

slhcvltd is offline
I have been posting on forums and looking for answers for almost 2 years now...here is the timeline of events and yet NO solution

2010

I have been using my WD external hard drive on my G5 Mac (OS X 10.4.11) at work for the last year or so with no problems. One day I plugged it in and it suddenly did not appear on my desktop. I tried the hard drive on 3 other macs in the building and also 2 PCs and my PC at home. They all access the hard drive and files just fine. I checked forums for any type of answer and nothing matches my exact problem and none of the suggestions for similar problems have helped. In Disk Utility the drive shows up. The Mount/Unmount button says "Unmount" which I would assume the mac thinks it's mounted. If I click to Unmount and then click Mount it says "The disk could not be mounted. Try running First Aid on the disk and then retry mounting." I then go to First Aid and repair the disk and it tells me that the disk does not need repair.

It was suggested that my mac may not be supplying enough power to the USB ports. So I unplugged everything but my mouse, keyboard, and hard drive out of the 5 available USB ports on my machine. I tried the hard drive on all the other ports. The mac detects the hard drive in both Disk Utility and System Profiler every time I plug it in but still does not mount to access the files. I have tried flash drives on all of these ports and those have no problems and mount fine.

The next suggestion was to run the Apple Hardware Test to see if there were problems with the USB ports. I ran the test and nothing is wrong. Then I was told to try the fix for "Invisible Drives" and that did not work.

After reading suggestions on other forums, I tried resetting the PRAM, which didn't work. It was also mentioned that getting a powered USB hub worked for almost everyone with this problem. But since this is my work computer, I wasn't able to talk my boss into getting one of those yet.

After some time I finally purchased a new external hard drive...another WD....with great confindence that it would solve my problem. I plugged it in and I had all the same problems.

2012

My boss finally got me a powered USB hub. With excitement that I would finally be able to use my hard drive on my own computer, I plugged it all in. Nothing. Same problem as before. The hard drive shows up in Disk Utility and System Profiler and still works on every other computer in existence, but will not mount on mine. Aside from buying a new computer myself (because my boss sure won't do it) I dont know what will fix this problem. PLEASE HELP!
QUOTE Thanks
louishen

 
louishen's Avatar
 
Member Since: Oct 22, 2007
Location: London
Posts: 8,945
louishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant future
Mac Specs: Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver

louishen is offline
Sounds odd, but I always run a combo update to freshen up a system that is behaving badly, in your case

Mac OS X 10.4.11 Combo Update (PPC)

try that first

Member of the Month September 2008 & August 2012 | Found advice useful? use the rep system
QUOTE Thanks
slhcvltd

 
Member Since: Aug 25, 2010
Posts: 6
slhcvltd is on a distinguished road

slhcvltd is offline
Quote:
Originally Posted by louishen View Post
Sounds odd, but I always run a combo update to freshen up a system that is behaving badly, in your case
I had already installed the combo update quite a while ago, but just to be sure I did it again just now and still no difference. Any other suggestions?
QUOTE Thanks

Post Reply New Thread Subscribe


« Apple wireless keyboard on PC (not bootcamp) | Problem with Ethernet to USB Adapter »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
External Hard Drive Choice tarheel Other Hardware and Peripherals 4 01-15-2012 05:11 PM
Another MacBook Hard Drive Replacement Experience caribiner23 Apple Notebooks 29 11-24-2011 01:16 AM
Itunes keeps copying my files from my external hard drive? Sas OS X - Operating System 1 04-11-2011 07:40 AM
Yet another stupid chick who can't access her external hard drive generic chick Internet, Networking, and Wireless 6 04-12-2010 07:17 PM
HELP: external hard drive not showing up on desktop Googly Other Hardware and Peripherals 3 11-28-2006 11:24 PM

All times are GMT -4. The time now is 03:34 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?