Results 1 to 3 of 3
  1. #1

    VetteTec's Avatar
    Member Since
    Jun 24, 2011
    Location
    Palm Harbor, Florida
    Posts
    18
    Specs:
    MBP 15" 2011, 2.53 I5, 600gb Intel SSD, 8g ram, OS 10.8.2, 27" Display
    Dell v515 Wireless Printer Mystery?
    Hey,

    I got this printer from a friend who has a late 2011 MBA running Lion 10.7.2.
    We demo'd the printer for me and was working perfect thru his wi-fi network so I picked it up for next to nothing.

    Make a long story short, came home with it and found out the drivers are only available up to 10.6.

    I have already updated to 10.7.3 on my MBP 15

    Tried to load the available drivers and got the message this software is not compatible with this OS.

    So here's the mystery, how was it working on his network with his MBA running 10.7.2 ?

    I asked my friend how he set it up, and being that he is a total NOOB worse than me, he has no clue. He said it just worked after a few days. I find that hard to believe, but yet it happened.

    Could the update be preventing the install? Or did he just have some stroke of major luck?

    TIA

  2. #2

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    22,391
    Specs:
    Imac 27", 3.3GHz, 512 flash storage, 16GB memory, macOS Sierra.
    Apple released some Lexmark drivers for OS X.7. Dell printers are usually re-badged Lexmark's so go through the list and see if there is anything similar.

    http://www.macupdate.com/app/mac/281...rinter-drivers

    Compartive models shown here:-


    http://www.shopping.com/xSBS-dell-si...7774-106562449
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  3. #3

    VetteTec's Avatar
    Member Since
    Jun 24, 2011
    Location
    Palm Harbor, Florida
    Posts
    18
    Specs:
    MBP 15" 2011, 2.53 I5, 600gb Intel SSD, 8g ram, OS 10.8.2, 27" Display
    Thanks harry. Found that the lexmark s405 is pretty much the exact same printer. I downloaded the drivers, Lexmark had the 10.7 drivers, went thru the "set up assistant", step by step and got stuck midway. It would not recognize the dell printer and go on with the install.
    Is there a step I'm missing?

    Any suggestions?

    TIA

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. AIO Dell Printer
    By jillziepoo in forum Other Hardware and Peripherals
    Replies: 5
    Last Post: 03-16-2014, 10:19 PM
  2. eMac wireless connection mystery
    By Octavius77 in forum Apple Desktops
    Replies: 2
    Last Post: 04-30-2012, 11:54 PM
  3. Dell Printer Drivers?
    By COMacUser in forum Other Hardware and Peripherals
    Replies: 7
    Last Post: 10-28-2010, 05:31 PM
  4. Dell V715w Printer?
    By sillysuperdog in forum Switcher Hangout
    Replies: 1
    Last Post: 04-29-2010, 06:02 PM
  5. Using - Dell All-In-One Printer 924
    By Spook in forum Switcher Hangout
    Replies: 0
    Last Post: 09-24-2008, 05:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •