Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Other Hardware and Peripherals (http://www.mac-forums.com/forums/other-hardware-peripherals/)
-   -   FAT formatting does not work on Firewire only. (http://www.mac-forums.com/forums/other-hardware-peripherals/256923-fat-formatting-does-not-work-firewire-only.html)

Dysfunction 11-11-2011 05:29 PM

FAT formatting does not work on Firewire only.
 
1 Attachment(s)
Well, this is interesting. I took a FW800 drive today (hitachi g-tech) that works great. Repartitioned it using HFS+ and FAT (MS-DOS FAT) using Disk Utility.

Awesome right?

Well, despite the fact that a linux box, a windows box, and a Snow Leopard box will mount the FAT drive just fine... the Lion box that formatted it? Yea.. not so much.

It mounts as a USB drive, connect it to FW and it just fails with.

11/11/11 2:15:45.046 PM diskarbitrationd: unable to probe /dev/disk2s3 (status code 0xFFFFFFFC).

11/11/11 2:15:45.000 PM kernel: disk2s3: I/O error.

So, anyone else with Lion.. give this a try.


Interestingly enough, I get the following window in disk utility.

Attachment 16191

vansmith 11-11-2011 05:36 PM

Have you tried mounting it manually (although I assume this is how DU does it anyway)? This seems like an odd issue.

Dysfunction 11-11-2011 05:43 PM

Yep. Same result.

Off to perform the Mac version of reboot... zapping the PRAM

Dysfunction 11-11-2011 05:52 PM

and that didn't work.

I'm chalking it up to another Lion bug. w00t.

vansmith 11-11-2011 07:26 PM

Quick question - do both partitions have the same name? This old hint seems to suggest that OS X doesn't like two partitions with the same name.

I'm in the dark here - if I find something, I'll post back.

Dysfunction 11-11-2011 07:41 PM

same name? nope.

If it was the name issue, I'd imagine it'd be a problem as a USB device too.

Dysfunction 11-11-2011 10:53 PM

reformatted the slice exFAT, and now it works.

/dev/disk1s2 on /Volumes/export (hfs, local, nodev, nosuid, journaled, noowners)
/dev/disk1s3 on /Volumes/exFatTest (exfat, local, nodev, nosuid, noowners) <-----


All times are GMT -4. The time now is 07:54 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.