Results 1 to 4 of 4
  1. #1

    Member Since
    Oct 05, 2011
    Angry Internal SSD Wont Initialize
    Hi Guys,
    So this is my first time posting, tell me if im doing anyting wrong

    I have a MacBook Pro 2.4 GHz Intel Core i5 Version 10.6.8.
    I recently bought an 80GB Intel 25x-m SSD drive over ebay. Because the drive is small, I also bought a caddy so that I could install a second hard drive in the optical bay. I heard there were hibernation issues when booting from the optical bay, so I took out the stock hard drive and moved it to the optical bay,then I installed the SSD in the regular Hard drive slot.

    Then I booted, and YAY, it worked. Unfortunately, I then tried to initialize the new SSD (Mac prompted me to do this) but it came up with this error, 'POSIX reports: The operation couldn’t be completed. Cannot allocate memory'

    So i tried many different things, including updating the firmware, zero-erasing the disk, using terminal to force unmount and zero-erase, transferring the drive to a windows computer and connecting it via a SATA cable and a USB cable and using windows to attempt to format (different error, still no format), partitioning, booting from a different disk!! It just goes on.
    If any of you geniuses on here can help me, I will be forever in your debt, im sick of this and I would just love for this to work.

    Thankyou in advance

    Will G

  2. #2

    Haalcyon's Avatar
    Member Since
    May 03, 2011
    2010 Mac Pro | 2011 15" MacBook Pro | 2009 13" MacBook Pro
    I wonder if you booted from OS X installation disk if Disk Utility would allow you to initialize it (and perhaps) install OS X on it.
    Macs? Oh yes, several.

  3. #3

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    It sounds to me like the Intel SSD may be defective. Get in contact with the seller on eBay and ask if it's possible to return it.

    Also, a bit of advice.... I would stay away from purchasing an SSD or any other hard drive from an eBay seller. Too easy to get burned and very difficult at times to return the defective item.

    Buy an SSD from a reputable seller such as Other World Computing.

  4. #4

    Member Since
    Apr 27, 2012
    The problem to initialize a new SSD
    I have the same problem. I have a new 120 GB SSD from OCZ. I put the SSD into an external USB closure and connected it to my macbook pro (mid-2012) via USB. Then, I partitioned using Disk Utility. The option is "GUID" and "Mac OS Extended (Journaled). Then it never completed. One time I left for more than 5 hours. Still processing.
    Then I moved to PC with win7. But even the PC could not format. I tested my friend's SSD (he had another 120 GB) but never resolved. Even his SSD could not get partitioned either.
    What is wrong??????

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can't transfer files from internal SSD to other drives (Error -36)
    By michetonu in forum OS X - Operating System
    Replies: 5
    Last Post: 08-12-2015, 11:04 PM
  2. New Internal SSD, no format.
    By x59 in forum Apple Notebooks
    Replies: 5
    Last Post: 03-19-2015, 07:48 PM
  3. SUPER SLOW SSD(3rdparty as internal) ON MAC OS
    By sally3 in forum OS X - Operating System
    Replies: 7
    Last Post: 03-07-2015, 03:40 PM
  4. Using an external ssd as an internal hard drive.
    By madonmac1 in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 11-27-2013, 04:40 PM
  5. Adding an internal HD to my SSD only 27 iMac?
    By Gary Irwin in forum Apple Desktops
    Replies: 7
    Last Post: 09-17-2011, 04:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts