Results 1 to 3 of 3
  1. #1

    Member Since
    Oct 01, 2011
    Question USB printer connected to USRobotics AP - Not working on Lion
    Dear All,

    I have a Samsung ML-1510 printer (SAMSUNG Semiconductor - Page Not Found) connected to a
    USR5461 802.11g Wireless MAXg Router (firmware (

    I need to print with this printer on my mac with Lion.. so:
    I just go to add printer -> IP
    Protocol: IPP
    Address: http://192.168.x.x:1631/printers/My_Printer
    Print using: Generic PostScript printer

    When I click on add I get this error: "error trying to add the printer. client-error-not-possible".

    I thought was a driver problem, so (since there are not samsung drivers for lion) I downloaded these: SpliX

    But the same error appears.

    I have tried to use only 192.168.x.x:1631/printers/My_Printer as Address, it let me add the printer (also if it does not find it) and it does not work.

    Can you please give me some advices on how I can solve this problem?

    Printer and router works fine (I can perfectly print from my laptops and pc either with WinXP or 7).

    Thank you for your help

  2. #2

    BrianLachoreVPI's Avatar
    Member Since
    Feb 25, 2011
    March 2011 15" MBP 2.3GHz i7 Quad Core 8GB Ram | Mid 2011 27" iMac 3.4 GHz i7 16 GB RAM 2 TB HDD
    Thread moved to a more appropriate forum.

  3. #3

    Member Since
    Dec 11, 2010
    Your printer isn't a postscript printer. (generic postscript driver won't work)
    All drivers to date from Samsung have been for local USB connection only.
    Install the Samsung-GDI driver set (three parts to install):
    macosx/samsung-gdi | The Linux Foundation

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 11-18-2012, 04:42 PM
  2. Network Printer not working - Mountain Lion
    By sapper268 in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 09-05-2012, 11:33 PM
  3. Replies: 1
    Last Post: 08-25-2011, 07:16 PM
  4. USB printer i've connected to Time Capsule isn't working
    By drummerkid1993 in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 08-31-2009, 05:07 PM
  5. iMac USB connected to printer sharing w/Microsoft XP
    By JDL51 in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 04-13-2009, 03:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts