Results 1 to 2 of 2
  1. #1

    Member Since
    Jun 22, 2011
    portable iOmega external hard drive not working at all!...please help!
    Hi, this is my first post, so please excuse me if I am in the wrong forum area, or if I do anything else wrong.

    I have a 500GB iOmega Prestige portable hard drive that seems to be frustrating me to no end. It was purchased about 3 years ago and worked up until recently.

    I suppose I will just start from the beginning. I have a 13" MBP. I tried to go into Disk Utilities (DU) and go through as many of the trouble shooting steps as i could fathom, and find on the internet. (FirstAid; repair disk, Erase, Partition, reboot Finder and then try all over again). nothing I did in DU worked, until finally one time something changed and now all I can see on the lefthand bar is the factory name of the external HD (500.11 GB ST950032...) and underneath that there is, in faint grey text, "disk1s2" (that appears to not be mounted). I have also tried to mount that disk without success. the drive does not apear on the desk top, and any attempt to repair, erase, or partition it fails with various messages.

    Currently when i plug the HD in VIA USB i get a alert that says "The disk you inserted was not readable by this computer" then it provides 3 buttons, Initialize, ignore, and eject. If i hit initialize DU opens with the HD on the left but non responsive to any actions.

    I hope there is still a chance I can get this sucker back in working order. I can and will provide screen shots and more info as needed.

    I hope I provided enough information to comprehend the problem.


  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    You're beating a "dead horse". Typically this is the way external hard drives die. It could be something mechanical, or electronic. Probably something in the drive electronics has failed unless it was dropped or mishandled.

    The best you can hope for now is to try to extract your data from the dead drive. I'm not sure that even recovery or repair software will work since the drive will not mount. It's possible the drive is covered under warranty. I don't know how long iOmega warrants them for but you can find out by going to their website.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iomega External Hard Drive Issues
    By EquineSparkle in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 06-13-2012, 06:08 PM
  2. Iomega Portable Hard Drive not mounting
    By seanachie in forum Other Hardware and Peripherals
    Replies: 12
    Last Post: 01-04-2011, 02:58 AM
  3. 500 GB Iomega eGo Helium Portable Hard Drive
    By G5flyr in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 10-03-2010, 02:28 PM
  4. Portable Hard Drive not working with USB Hub?
    By bestmbp15 in forum Apple Notebooks
    Replies: 1
    Last Post: 08-31-2010, 05:24 PM
  5. Help- Iomega external hard drive
    By gary in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 07-17-2007, 01:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts