New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

External Hardrive was working and now doesn't mount


Post Reply New Thread Subscribe

 
Thread Tools
domarisdione

 
Member Since: Sep 05, 2010
Location: Boston
Posts: 2
domarisdione is on a distinguished road

domarisdione is offline
Hi there,

I have a harddrive that I set up and transferred files to. It started disappearing from my desktop and telling me it'd been improperly disconnected when my MacBook went to sleep. It has since stopped mounting entirely. It lights up when connected via USB but I can't access it. I looked in the disk utility and it doesn't show up at all. I'm running OS X Version 10.6.4. Any help would be much appreciated...

Thanks!
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 39,485
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is online now
It's possible that your external hard drive is defective. Try mounting it on another computer if possible. PC or Mac. If the drive refuses to mount on another machine and is still under warranty, call the manufacturer's tech support and ask for a RMA.
QUOTE Thanks
domarisdione

 
Member Since: Sep 05, 2010
Location: Boston
Posts: 2
domarisdione is on a distinguished road

domarisdione is offline
For whatever reason once I opened it on a PC it started mounting normally on my MAC again. Weird. Thanks!
QUOTE Thanks

Post Reply New Thread Subscribe


« External hard drive enclosure recommendations | Connecting PowerBook G4 12" to 1080p Insignia 26" LCD HDTV »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 02:44 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?