New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus ē Advice and insight from world-class Apple enthusiasts ē Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

WD My Book Studio Edition II wonít mount on desktop! Help!


Post Reply New Thread Subscribe

 
Thread Tools
editionfive

 
Member Since: Apr 19, 2010
Posts: 3
editionfive is on a distinguished road

editionfive is offline
Hi, Iím hoping someone could shed some light and let me know how to fix this problem. The My Book Studio Edition II that Iíve been using for 5 months (only) suddenly wouldnít mount on my PowerBook G4 (Mac OSX 10.4.11). I tried using Disk Utility and I could see the drive and the icon is dim. When I clicked ďmountĒ it still wouldnít mount, the drive is still showing dim. The WD driver manager also showing the drive in good status and good condition on the menu bar and has the green light. The power light/LED status and activity lights seemed acting normal, it goes in & out when I tried to mount it. And I could hear the sound that normally when the drive is landed on the desktop. However, itís not there. I tried using different cable - Firewire 400, 800 and USB cable and it still wouldnít work.

I donít know if itís caused by the new Macbook Pro (latest Mac OSX Snow Leopard) I recently purchased. The whole problem started when I plugged the external MyBook HD to the new Macbook Pro to transfer some files, it was working, but then when I plugged it back to the Powerbook G4, itís just not showing. I then tried to plugged it again to the new Macbook pro, not showing either. I have the My Book HD configured in RAID 1 with no password at the moment.

I also bought another My Book Studio Edition II HD two weeks ago (donít know now if this is a good idea now!!). Iím using it with the Macbook Pro with Time Machine. At the moment seems to be working ok. But Iím not dare to plugged it in to the Powerbook G4, just in case it disappear on both laptops. I apologise for the long posting, but I think Iíve coveredd all the issues that I encountered. I hope the drive will come back so I can get back all the data (900MB) in it.

Thanks so much for your help in advance.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 38,429
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is online now
I don't know if this will help or not.... The WD My Book Studio Edition II is a RAID unit and as such if one of the drives fails or malfunctions for some reason or another, the entire unit will not mount. I don't believe you did it any harm by moving it from the G4 to your new MBP. The failure was probably coincidental.

You might want to contact Western Digital support by phone (they have a toll free number) and see if they can work with you to trouble shoot it. The unit should still be under warranty. They should also be able to tell you how to get your data off the drive(s) if possible. There is also software available that can help recover your data, if necessary.

Regards.
QUOTE Thanks
roffir

 
roffir's Avatar
 
Member Since: Mar 21, 2008
Location: Boston, MA
Posts: 153
roffir will become famous soon enough
Mac Specs: MacBook Pro | iMac | iPhone 4

roffir is offline
Did you try repairing permissions in disk utility? If that doesn't work you may need Disk Warrior. This happened to me once and it just need to be repaired by disk utility if it can or if not you'll need to rebuild with disk warrior depending on how valuable the files are stored on it.
QUOTE Thanks
editionfive

 
Member Since: Apr 19, 2010
Posts: 3
editionfive is on a distinguished road

editionfive is offline
Thanks for your reply @chscaq and @roffir.
I tried contacting the support from WD, they said that will give me a call back, but Iím still waiting.

I also tried using Disk Utility/Disk Warrior/Drive Genius to mount or verify and repair. But none of this worked. The error message came up and said my disk is damage. The strange thing is that it shows the drive condition is good and healthy in the WD drive manager with the green light on. Thereís no clicking or any strange sound from the drive.

As the drive itís configured in RAID 1, and possibly not both of the hard drives are damaged. Iím thinking of getting a enclosure and try to get the data back from this way. Does anyone know which enclosure I need to get? I could probably get one from Amazon.co.uk, but I donít know which one to get. A eSata one with USB interface? 2.5Ē or 3.5Ē? Is it easy to assemble it? Your advice would be much appreciated!
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 38,429
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is online now
Quote:
As the drive itís configured in RAID 1, and possibly not both of the hard drives are damaged. Iím thinking of getting a enclosure and try to get the data back from this way. Does anyone know which enclosure I need to get? I could probably get one from Amazon.co.uk, but I donít know which one to get. A eSata one with USB interface? 2.5Ē or 3.5Ē? Is it easy to assemble it? Your advice would be much appreciated!
You might be better off using a universal drive adapter rather than an external carrier. Here's the LINK to OWC (located in the US) as it will give you some idea of what to purchase. I'm sure Amazon UK stocks the same item.

Regards.
QUOTE Thanks
editionfive

 
Member Since: Apr 19, 2010
Posts: 3
editionfive is on a distinguished road

editionfive is offline
Quote:
Originally Posted by chscag View Post
You might be better off using a universal drive adapter rather than an external carrier. Here's the LINK to OWC (located in the US) as it will give you some idea of what to purchase. I'm sure Amazon UK stocks the same item.

Regards.
That's very good idea, thanks! I'll definately buy one of this.
Good news is that WD is sending me a replacement drive, so I'll swap the old to the new to get the data back.

Thanks all for your advice.
QUOTE Thanks

Post Reply New Thread Subscribe


« Opening a wireless keyboard (A1016) - What size torx? | Magic Mouse swipes not! »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
FAT Partition won't mount on Mac Desktop wildnight Running Windows (or anything else) on your Mac 1 01-23-2007 10:38 AM
noob question... can you mount a terminal to the desktop? jamesmccain Switcher Hangout 7 09-05-2006 02:11 PM
Make my digital camera mount on the desktop? edokid OS X - Operating System 0 03-06-2006 09:44 AM
N-gage MMC doesn't mount on desktop anymore koert Other Hardware and Peripherals 3 03-31-2005 05:37 AM
Digital Camera mount Desktop? pcrap Other Hardware and Peripherals 2 12-18-2004 06:53 PM

All times are GMT -4. The time now is 02:49 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?