New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

WD My Passport not working


Post Reply New Thread Subscribe

 
Thread Tools
Alkt03

 
Member Since: Oct 27, 2009
Posts: 10
Alkt03 is on a distinguished road

Alkt03 is offline
Hey everyone, I've been using a WD My Passport 500gb for about 4 months and so far and I've had no problems with it until today. I ejected it and about 30 minutes later I went to plug it back in. The WD smartware popped up, but my hd didn't. I'm not really sure what I did if anything to cause this. I don't know if this is a big deal but the light on the hd is blinking. I've never noticed if it always does this or if it means something else. The disk inside is spinning too. I have almost everything on this thing...does anyone know what may be wrong with it and how to fix it. Thanks in advanced
QUOTE Thanks
Kevriano

 
Kevriano's Avatar
 
Member Since: Jul 02, 2006
Location: Crawley, England
Posts: 4,561
Kevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to all
Mac Specs: 20" Intel iMac 2.4 Ghz/3G Ram/320HD, Snow Leopard. PBook G4, 1.5Ghz/1.5 Ram/250 HD, Leopard 10.5.6.

Kevriano is offline
First, unplug the WD from the mains and then restart it, see if it shows up then.
Next, check your USB connection and try a different cable.
Third, open disk utility and see if the drive shows up.

The blinking light on my old WD meant that it was in sleep mode.

Report back after trying these things.

Try my custom Mac Forums Search Engine: Mac Forums Google Search

Please use the reputation system if you consider any help given useful (it's the little ✓/✘ on the left <---)

QUOTE Thanks

Post Reply New Thread Subscribe


« Using your BlackBerry as a mouse | iMac add-on - use it as a AV or HD monitor »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
PowerBook Keys (occasionally) not working cds311 Apple Notebooks 1 03-31-2009 12:05 PM
Another wireless not working issue... RunningMac Internet, Networking, and Wireless 1 03-29-2009 09:01 PM
DSL suddenly not working on Mac, Working fine on Windows Sr-ultimate OS X - Operating System 1 02-15-2009 06:40 PM
The same keys not working after changing keyboard? thorneyvilla Apple Notebooks 0 11-19-2008 09:38 AM
Help! preview, ms office, adobe reader not working attackeagle OS X - Apps and Games 1 08-24-2008 03:12 AM

All times are GMT -4. The time now is 08:35 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?