Results 1 to 2 of 2
  1. #1

    Member Since
    Oct 27, 2009
    WD My Passport not working
    Hey everyone, I've been using a WD My Passport 500gb for about 4 months and so far and I've had no problems with it until today. I ejected it and about 30 minutes later I went to plug it back in. The WD smartware popped up, but my hd didn't. I'm not really sure what I did if anything to cause this. I don't know if this is a big deal but the light on the hd is blinking. I've never noticed if it always does this or if it means something else. The disk inside is spinning too. I have almost everything on this thing...does anyone know what may be wrong with it and how to fix it. Thanks in advanced

  2. #2

    Kevriano's Avatar
    Member Since
    Jul 02, 2006
    Crawley, England
    20" Intel iMac 2.4 Ghz/3G Ram/320HD, Snow Leopard. PBook G4, 1.5Ghz/1.5 Ram/250 HD, Leopard 10.5.6.
    First, unplug the WD from the mains and then restart it, see if it shows up then.
    Next, check your USB connection and try a different cable.
    Third, open disk utility and see if the drive shows up.

    The blinking light on my old WD meant that it was in sleep mode.

    Report back after trying these things.
    Try my custom Mac Forums Search Engine: Mac Forums Google Search

    Please use the reputation system if you consider any help given useful (it's the little ✓/✘ on the left <---)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My Passport
    By EmmEff in forum OS X - Operating System
    Replies: 8
    Last Post: 07-17-2014, 04:07 PM
  2. my passport
    By louisag in forum Apple Notebooks
    Replies: 5
    Last Post: 01-11-2013, 03:19 PM
  3. My Passport
    By mbeach in forum Switcher Hangout
    Replies: 2
    Last Post: 05-23-2012, 11:09 AM
  4. Help with a WD My Passport? Please? :)
    By chrstn in forum Other Hardware and Peripherals
    Replies: 4
    Last Post: 09-30-2010, 09:00 PM
  5. WD Passport!
    By bearded_trout in forum Other Hardware and Peripherals
    Replies: 4
    Last Post: 09-12-2008, 10:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts