Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Other Hardware and Peripherals (http://www.mac-forums.com/forums/other-hardware-peripherals/)
-   -   Problems saving iWork documents to Server... (http://www.mac-forums.com/forums/other-hardware-peripherals/198190-problems-saving-iwork-documents-server.html)

sam6 04-12-2010 12:34 AM

Problems saving iWork documents to Server...
 
Hi Everyone,

We have a client with about 30-40 users who are having issues saving iWork files onto their XServe running 10.6. Every time they try and modify a document in mainly, Numbers or Pages it is giving them errors, I don't have the specific ones at this time. So they have to drag the documents to their Local Desktop, save and then drag drop back into the Server folder, they all have read and write access to these documents. So I am thinking it could be some sort of weird permissions problem.

Anyone have any ideas? Ta

sam6 04-13-2010 07:53 PM

Update"""

Went to the client's office yesterday, basically it wasn't a problem with iWork itself, basically the problem lies with Apple's Preview. We tested Saving As from Apple's Preview into certain folders and it told us we didn't have the right permissions, even though we stripped the ACL permissions using BatChmod and then re-applied a numerous amount of times to all the staff in the office, even if we drag and drop the from the local desktop it works fine, it just seems to happen when saving from Preview itself, very strange. Most folders on the XServe directories it doesn't seem to have a problem saving to, but there are a few it doesn't like which is even stranger. Tested whether it was a problem between 10.5 and 10.6 but both systems seemed to have the same issue. We tried saving .docx and .docs and pages documents into the same folders and they worked fine also... any ideas?

chraebs 05-23-2011 02:33 AM

sorry for reviving such an old discussion...

I'm having the exact same problem with the iWork-applications Pages and Numbers. If somebody saves a file on the server, the file only has full permission for the creator and reading-rights for the creators-group.
"Normal" applications don't care, because they follow the ACL-Rules. It seems Pages, Numbers and also the already mentioned Preview won't follow the ACL-Rules but stick to tht POSIX-Rules.

[edit]
We also noticed, this problem doesn't only occurs on 10.6 Clients. Clients running 10.5 also have the same problem.

Still nobody knows a practical solution for this problem?

alanroseman 02-21-2013 03:17 PM

Pages will not save to sever folders
 
I have just begun to experience this issue. All other applications can save to server folders, Pages produces a Permissions Error on every save attempt.

Has anyone defeated this issue?


All times are GMT -4. The time now is 06:58 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.