New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

My new USB Card Reader dont mount.


Post Reply New Thread Subscribe

 
Thread Tools
Tassos

 
Member Since: Feb 18, 2010
Posts: 2
Tassos is on a distinguished road

Tassos is offline
Hello all,

I've just bought a new card reader (Crypto UR-160).

The problem is that it just does not mount in order to have access in the data of my memory cards.

I have an iMac late 07 with Snow Leopard 10.6.3 with all available updates.

The first think I did was to check to all available usb ports, both in keyboard and in main unit/screen.
Then to change cable.

I've checked in system profiler-> USB and I can see that the card reader is recognised and this is the info I get:
Mass Storage Device:

Product ID: 0x6364
Vendor ID: 0x058f (Alcor Micro, Corp.)
Version: 1.00
Serial Number: 058F63646476
Speed: Up to 480 Mb/sec
Manufacturer: Generic
Location ID: 0xfd100000
Current Available (mA): 500
Current Required (mA): 250

Of course except that information nothing else happens (no mount and not any other message when connected/disconnected)

I've tried to see if I can 'see' it in my Win XP via VMware.
The card reader is recognised and I can see the data withing the memory card, however it works erratically as every few seconds (10-20'') is re-installed. So that means that for any reason is continuously connects and disconnects.

Then I've tried to see if it works in a normal Windows pc. It works fine with no problem.

I return it to the shop I bought it.
There we have connected it with a MB with 10.5.something and works fine
We connect it also to an iMac with 10.6.2 and works fine.

In my iMac does not

I've never had this kind of problem in the past.

I have already 2 more card readers that work fine.
I've just bought the new one for the additional card options and for the microSD that the others dont have.
Also several USB memory sticks has connected in the past in my iMac with no problem.

Is there any idea why I have this problem and how can I solve it?

Some additional info:
I cannot see any of the attached cards in disk utility (I've used two different types of memory cards).

Once more the crucial (I believe question). Why I can see it in System Profile but is not mounted?

Thanks in advance.

Tassos.
QUOTE Thanks
Corbab

 
Corbab's Avatar
 
Member Since: Oct 13, 2009
Posts: 306
Corbab will become famous soon enough
Mac Specs: MacBook Pro, 2.53 GHz, 4 GB DDR3, 250 GB HDD, 10.6.4

Corbab is offline
First of all, how is it formatted? I'd be surprised if it worked on one Mac and not another, but you never know...

This is a huge long shot, there's a slight possibility that you have a hardware issue. My old MB had a bad logic board, and it stopped recognizing my iPods a few months before I noticed anything else.

Other than that, I've got no idea what your problem might be. Good luck with that...

Just a stupid kid with a computer, so take my advice with a grain of salt if that makes a difference to you.
QUOTE Thanks

Post Reply New Thread Subscribe


« Permissions problem when copying from backup | I need a mac compatible printer! »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Belkin USB 2.0 PCI card Rottie Other Hardware and Peripherals 3 01-07-2010 05:15 PM
Firewire CF card reader vs USB 2.0 - which is faster? wrightm Images, Graphic Design, and Digital Photography 1 10-14-2008 06:22 PM
card stuck in card reader, able to be read srmorris2 Images, Graphic Design, and Digital Photography 6 06-11-2008 01:03 AM
small mouse and card reader rootrageous Other Hardware and Peripherals 11 06-02-2007 02:43 PM
Why no builit in card reader?? Xyphos Switcher Hangout 24 04-17-2007 10:00 PM

All times are GMT -4. The time now is 02:25 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?