Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Other Hardware and Peripherals (http://www.mac-forums.com/forums/other-hardware-peripherals/)
-   -   Mac won't read USB MicroSD card anymore (http://www.mac-forums.com/forums/other-hardware-peripherals/196537-mac-wont-read-usb-microsd-card-anymore.html)

Kitxune 03-30-2010 01:13 AM

Mac won't read USB MicroSD card anymore
 
Alright, my Mac decided to throw up my USB and doesn't want it anymore.

I have a 2GB MicroSD card with a USB adapter that i've been using with this computer smoothly for about a year. Today, i tried to move a folder from my computer onto the card, and it didn't work. It promptly closed the USB's window and gave me the "improper device removal" notice.
I tried reinserting the USB in different ports and restarting the computer, to no avail. The card itself is still working fine. My computer just doesn't want it anymore. :| It's kind of important... What happened, and what can I do to fix it?

I'm on a Mac OS X version 10.4.11 (Tiger).

The device does not seem to show up in the System Profiler under USB either.

P.S. - Sorry if this is in the wrong forum or if it's been answered before, i looked.

macguy57366 03-30-2010 09:04 AM

Almost sounds like the reader went and died overnight. Does it have a removable USB cord? If so, then try another cord for it; if not, then you might have to buy another one unless someone else here finds another cause.

Kitxune 04-02-2010 12:47 PM

Ah, sorry my reply is so late.

Well, it seems to be working on other computers so it's likely something wrong with my Mac... =/

There is no cord, it's um.. a mini USB adapter, where you put the MicroSD card directly into the USB thing. The port on the Mac seems to be working fine, because when I plug other things into it they work. My Mac just ignores this one adapter.


All times are GMT -4. The time now is 04:49 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.