Results 1 to 2 of 2
  1. #1

    Member Since
    Mar 15, 2010
    Manually install Update/Firmware? Downloads great, Install fails
    I have been trying over and over again to update my apple tv to the latest version (3.0.2) of the software. It downloads the update just fine and then I select update now. It shows the apple logo and begins the update, progress bar shows movement until 3/4 of complete then I get the awesome, very descriptive answer "Your apple TV cannot be updated". Earth shattering, the apple TV programmer should have just written "If you don't own a protection plan we just found a new way to charge you because you are going to have to call us to fix this now sleek looking box in front of your TV" or "I am too busy to give you a proper error code" or "The sky is Blue" or "PEBKAC Error (Problem Exist Between Keyboard And Chair)" at least I would have laughed.

    Back to the issue:
    So after the GREAT ERROR MESSAGE the Apple TV takes me to the Apple TV recovery menu and 3 options, 1. Restart Apple TV (does nothing except loop back to the recovery menu), 2. Run Diagnostics, 2. Factory Restore. I have tried all 3 options, diagnostics says its running correctly (every time). However now that I've done a factory restore I went from being stuck on 3.0.1 (which WORKED!!) to 1.1.

    Any suggestions on how to get the upgrade and install to work?


    Does anyone know how to manually install firmware onto your Apple TV?

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    This appears to a case of "If it ain't broke don't fix it". Personally I stay away from firmware updates unless it addresses a specific problem I'm having. Updating to the latest and greatest firmware can sometimes lead to other issues.

    I suggest trying to obtain the original firmware update (3.01) from Apple and applying that since it was the last firmware release that worked. I suspect that the firmware update (3.02) was either not applicable for your Apple TV or you downloaded a corrupt update.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yosemite install fails
    By stravaign in forum OS X - Operating System
    Replies: 6
    Last Post: 10-18-2014, 11:53 AM
  2. Replies: 10
    Last Post: 09-07-2014, 03:11 AM
  3. PPC G4 Mac mini fails to boot from install disc
    By stevieboy in forum OS X - Operating System
    Replies: 13
    Last Post: 07-06-2008, 02:40 PM
  4. Install validation fails and corrected
    By DesertSage in forum OS X - Operating System
    Replies: 0
    Last Post: 10-29-2007, 02:54 AM
  5. tiger install / printer fails
    By andybak in forum OS X - Operating System
    Replies: 2
    Last Post: 05-19-2005, 07:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts