Results 1 to 2 of 2
  1. #1

    ImageX's Avatar
    Member Since
    Aug 17, 2009
    East Bay, CA
    17" MBP C2D 2.8 4GB OS X 10.8 | iPhone 5
    Steel Series WoW Gaming Mouse.
    I just got the aforementioned mouse as a Christmas gift and love it so far. There is however, one thing I wish I could disable to make it handle a bit better. Ever notice how when you move your mouse slow the pointer moves slowly, but when you move the mouse faster the pointer "covers more ground" and moves faster and farther? Is there a way to turn this function off so that the mouse just moves at one speed? This messes me up a bit when in the game and trying to click on things and the mouse either moves too slow or too quick and I miss what I wanted to click on. Thanks.
    "The early bird gets the worm, but the second mouse gets the cheese."

    Remember to use the Reputation System!

  2. #2

    Member Since
    Jul 14, 2008
    Scotland, UK
    nMP 6-core/32Gb/D700/512Gb: rMBP 15" 2.3GHz/16Gb/512Gb: iPhone 6 128Gb: iPad Air 2 128Gb: NEC PA322U
    Have a look for a a setting called 'Acceleration' and turn it off.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mouse help for wow
    By tallmanuk32 in forum OS X - Apps and Games
    Replies: 0
    Last Post: 05-09-2012, 05:53 AM
  2. Mac for Gaming/WoW graphics issues
    By north_guy in forum OS X - Apps and Games
    Replies: 7
    Last Post: 03-03-2011, 01:14 PM
  3. Mouse problems in WoW
    By Lanwee in forum Switcher Hangout
    Replies: 1
    Last Post: 06-29-2010, 10:47 AM
  4. WOW! An Expensive Mouse!
    By baggss in forum Schweb's Lounge
    Replies: 14
    Last Post: 12-28-2009, 05:20 PM
  5. Mouse problems on WoW
    By GoodTimeJoey in forum Switcher Hangout
    Replies: 4
    Last Post: 08-19-2008, 11:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts