Results 1 to 8 of 8
  1. #1

    Member Since
    Dec 15, 2009
    CanoScan LiDE 50 scanner not working under SANE
    I work at a local high school and we have a lot of "legacy" hardware. We have a couple of CanoScan LiDE 50 scanners we'd like to use. We have Intel iMacs running Leopard 10.5.7 on them. Of course, Canon (in a polite email) does not support this scanner in Leopard. I would use VueScan, but the money for it is not available.

    I turned to SANE, which has been coded into Tiger, Leopard, and Snow Leopard. The CanoScan is supported. The problem is that I can't seem to get it configured use the SANE Preference Pane. Has anyone else had this sort of issue and/or is familiar with SANE? I know I must be doing something wrong, but I just can't seem to figure it out.

  2. #2

    Jaygray's Avatar
    Member Since
    Mar 04, 2008
    Unibody MacBook Pro 2.26, 4gb RAM, 500gb HD
    I use a Canon LiDE 25. I have used it with both Leopard and Snow Leopard. Canon says it isn't supported, but it works. I use CanoScan Toolbox X which I believe you may be able to download from the Canon site. It doesn't work with my USB hub. I have to plug the scanner directly into my MBP, so I only plug it in when I need to use it, but overall it works well.

    I am not familiar with the differences between the LiDE 25 & 50. But if it's a software problem, perhaps the CanoScan software will help...

  3. #3

    Member Since
    Dec 15, 2009
    CanoScan LiDE
    I tried using Canon Toolbox first. I ending up emailing Canon support and they told me they did not support the CanoScan on Leopard. I did not have any luck getting it to work although I do have a CanoScan 8600 which works great with Canon's software.

  4. #4

    yogi's Avatar
    Member Since
    Jan 14, 2005
    St. Gallen, Switzerland
    iMac Core i5, iPad, iPhone 4
    I've had huge issues with scanners on Mac OS X - until Snow Leopard, which seems to have beefed up its Image Capture app. At the low price, I'de recommend pestering your school IT manager to get it.

  5. #5

    Member Since
    Dec 31, 2009

    I just tried getting a CanoScan LIDE 50 to work with my MacBook tonight (runnning 10.6.2). Yogi's right - Image Capture in 10.6 is said to be significantly better, though I'm not exactly sure how yet. I've pretty much ruled out the Canon drivers and Toolbox software, and have uninstalled them. I'm working with SANE now and can get it to see the scanner and show a preview, but it's unstable. I did install all the SANE components from the project page: that is, the scanner driver pack, libusb and gettext, the SANE TWAIN package, the pref pane, etc. At least I can get the scanner to make noise and throw something up on the screen. I'll let you know if I find a solution, but if you have time to kill, I would look at the SANE tools, rather than the Canon tools.

    As a side note, if I was less technically adept, this would have been the second time I would have to get rid of a Canon LIDE scanner due to software incompatibility. (The first time was in 2001 when my other LIDE scanner refused to work with OS X, and SANE wasn't really mature yet.) I like these scanners, but the environmental impact of this "planned obsolence" is, in this geek's opinion, careless and short-sighted on Canon's part. I'd happily pay twice as much for the scanner if they'd guarantee support down the road. Now, my next scanner will probably be a NeatReceipts unit.

  6. #6

    Member Since
    Dec 31, 2009
    Talking Update... got it working!
    OK, turns out I have a LIDE 30 instead of a LIDE 50. Same difference; Canon refuses to support it on 10.6.

    Here's what I've gathered from my research. The SANE package allows all sorts of previously-incompatible scanners to be used. Install the back-end, good deal. However (and here's where my understanding is still a bit shaky) the Image Capture app doesn't actually talk directly to SANE. Image Capture needs a TWAIN source, which is why you need to install the TWAIN-SANE bridge software.

    However, the TWAIN-SANE package is apparently quite unstable. This could explain why my LIDE scanner was dropping on and off with Image Capture. Photoshop also acted up when I tried to import from the LIDE (again, through the TWAIN package, which makes it available to all TWAIN-capable apps).

    The result is that we need some kind of software that talks directly to SANE, without the unstable TWAIN converter. You can do this through the command line using the "scanimage" command, which is sort of kludgy and probably not acceptable for your students. There is, however, an app called Snac which talks directly to SANE. It's been working GREAT for me, and has a nice simple interface! Get it here: Snac - Mac OSX GUI for SANE scanimage

    One caveat, however; I noticed that Snac is set to do a greyscale or black-and-white scan by default. When I tried previewing or scanning in that mode, I got an error saying that the mode was not supported. Changed it to Color and all was well!

    Snac only saves in TIFF, so you'll have to make sure people then convert them in Preview so your hard drives don't get filled up unnecessarily. If you're clever, you can also just make/find an Automator action / droplet that will convert them to JPEG when the TIFFs are dragged on to it.

    There's also a command called sane-find-scanner that you can use in Terminal to verify that SANE can actually see your scanner in the first place. Just plug in your scanner and type in the command; see if it detects it.

    Hope this helps, and good luck. I can't stand it when good hardware is wasted due to lack of good drivers!

  7. #7

    Member Since
    Dec 15, 2009
    I want to thank everyone who contributed to this thread, in particular "wherehouse" who provided me with the solution that finally worked with the SANE backend. Way to go!

    In summary - Canon does not support the CanoScan LiDE 50 for Leopard (I couldn't get it to work on Tiger or Windows XP, either). However, the SANE backend (ported for Leopard by Mattias Ellert) is available for Leopard. Load the "libusb" first and then load the "Sane backends". Go to Snac - Mac OSX GUI for SANE scanimage and download Snac. Launch it and make sure the CanoScan is attached to a (powered) USB port and scan away. It is a very simple frontend which is perfect for my high school students. Yes, they can play complex video games, use Facebook and Twitter, email like crazy, but scanning............. This does not bode well for our Social Security checks.

    Once again, thanks "wherehouse" and MacForums! Problem solved!

  8. #8

    Member Since
    Jan 11, 2010
    Hi Noticed this thread as I am setting up a Lide 50. It is possible to get the Canon drivers
    to work but so far only for the Canon toolbox app. After installing the toolbox, you then install the driver. It prompts for an install location and you have to drill down into the Canon toolbox folder and then the subfolder plugins. Once that is done you are good to go. I would still like to get it going with image capture and preview, maybe I will figure that out too. I am new to Macs but been a windows support engineer for many years.
    PS I have a new MBP with snow leopard.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Canoscan 8800F scanner very temperamental
    By ibisbill in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 07-26-2015, 09:10 PM
  2. CanoScan LiDE 110 problem
    By Jaycey in forum Images, Graphic Design, and Digital Photography
    Replies: 6
    Last Post: 10-04-2012, 11:57 AM
  3. Scanner not working after Snow Leopard upgrade
    By Emily Aloha in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 06-05-2011, 08:44 PM
  4. Canon LIDE-30 Help please
    By cheo3011 in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 12-21-2007, 07:44 PM
  5. CanoScan 8400F Film Scanner for Mac?
    By mode7girl in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 12-29-2005, 12:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts