I tried using the search menu but didn't find any help with what happened tonight to me and my mac.
I have the 20"imac running SL, a wired keyboard (want the keypad!) and a wireless mightymouse. Never had a problem with it in all these months I have owned it until tonight. (and here MIGHT be my problem...) I was playing World of Warcraft when, I believe, their server went into a huge lag. I got out of the game (had to force quit), and then when I tried to click on any program, I could not get a response. No biggie I thought..just restart. Nada. Wouldn't LET me restart. It just did not respond to my mouse commands even though I could move the cursor. I shut it down using the button. After turning back on..same thing. No mouse response. (btw new batteries in it last week).
I tried different methods of shutting down and restarting, all to no avail. Also, each time it was turned on, the mouse started in the upper left hand corner and when I moved the cursor, an additional black arrow STAYED in the corner while I moved a second (first?) one.
After about 3 hours of trying different keyboard commands, it started working again even though I had not done or changed anything yet. Just started working again!
I have a call into the Applecare folks and they are set up to call me tomorrow but now that it's working, do I cancel that and have NO IDEA what happened or if it will happen again? Do I tell them all of this and hope they can run some kind of diagnostics for me?
It was harrowing to say the least because it lasted around 3 hours or so. Next time could be longer...who knows?