New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

My Macs can not print using CLP 510


Post Reply New Thread Subscribe

 
Thread Tools
Sharpshooter

 
Sharpshooter's Avatar
 
Member Since: Sep 07, 2009
Location: Oklahoma
Posts: 36
Sharpshooter is on a distinguished road
Mac Specs: Macbook Pro Core2 Duo 4Gb Ram / Powermac G5 2 TB RAID , 16GB Ram Running Leopard

Sharpshooter is offline
Title says it all. I have a Samsung CLP 510 on my network at home and even though I have the drivers installed I still can not print using this printer from either one of my Macs. The printer is connected to my network using a print server. Windows computers have always been able to talk to it and I could print to it from a Mac using a Windows computer as a print server . I have been working towards getting rid of all my Windows computers and really do not want to keep one on the network. I have been told it would work with an Airport base but I have a wireless N router and a Belkin print server in place. Both my Macs can print to a all in one HP on the network but it is an inkjet. Any suggestions that do not include getting another printer or keeping a Windows box running would be welcome. I appreciate it.

"All great change in America begins at the dinner table."-Ronald Reagan
QUOTE Thanks
Sharpshooter

 
Sharpshooter's Avatar
 
Member Since: Sep 07, 2009
Location: Oklahoma
Posts: 36
Sharpshooter is on a distinguished road
Mac Specs: Macbook Pro Core2 Duo 4Gb Ram / Powermac G5 2 TB RAID , 16GB Ram Running Leopard

Sharpshooter is offline
The print queue was improperly configured I got it thanks!

"All great change in America begins at the dinner table."-Ronald Reagan
QUOTE Thanks

Post Reply New Thread Subscribe


« Rescuing a Mac | Best cooling pad while gaming »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Print from FedEx.com using Zebra ZP500 Thermal Label Printer SF2Shanghai OS X - Operating System 1 05-06-2009 02:04 PM
Need help setting up wired LinkSys Print Server drgrafix Switcher Hangout 0 02-17-2008 03:03 PM

All times are GMT -4. The time now is 05:15 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?