New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

Cinema Display won't turn on when USB's connected


Post Reply New Thread Subscribe

 
Thread Tools
Josh Behan

 
Member Since: Oct 30, 2009
Posts: 3
Josh Behan is on a distinguished road

Josh Behan is offline
Hey all,
My 30" cinema display has worked fine since I got it (used) a couple weeks ago. I tried moving it to another computer, and found that with the USB/Firewire connected, the display won't turn on. Unplug them, and it works fine. I had them plugged in when it was attached to the other computer, and everything was fine, so it seems to be an intermittent problem.

Does anyone know a solution for this?

Thanks in advance

Josh
QUOTE Thanks
apw2607

 
Member Since: Jan 04, 2010
Posts: 1
apw2607 is on a distinguished road

apw2607 is offline
Quote:
Originally Posted by Josh Behan View Post
Hey all,
My 30" cinema display has worked fine since I got it (used) a couple weeks ago. I tried moving it to another computer, and found that with the USB/Firewire connected, the display won't turn on. Unplug them, and it works fine. I had them plugged in when it was attached to the other computer, and everything was fine, so it seems to be an intermittent problem.

Does anyone know a solution for this?

Thanks in advance

Josh
Hello Josh.

I'm having exactly the same problem with my smaller 23" cinema display. Its worked fine for several years, and then suddenly no longer works if (and only if) the USB and/or the firewire cables are connected to the Mac. I've tried other Mac computers and its the same!

Did you resolve the issue?

Thanks.
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 18,138
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz, 16GB memory, OS 10.10.1

harryb2448 is offline
Scroll through these links from Apple Discussions:-

Apple - Support - Discussions - USB and Firewire not working ...
QUOTE Thanks

Post Reply New Thread Subscribe


« Canon MP980Won't Print Black | Firewire or USB 2.0 for external burn drive on G4 tower? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Dual Cinema display setup help! ETR Creasy Apple Desktops 2 12-21-2008 10:49 AM
Trying to run new 20" Cinema display with older style DVI port asiageof Apple Desktops 1 11-10-2008 02:12 PM
Cinema HD Display MuffinMan Other Hardware and Peripherals 0 12-21-2003 01:51 PM
30in Cinema Display? schweb Apple Rumors and Reports 6 03-15-2003 11:10 PM

All times are GMT -4. The time now is 07:52 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?