Results 1 to 3 of 3
  1. #1


    Member Since
    Oct 30, 2009
    Posts
    3
    Cinema Display won't turn on when USB's connected
    Hey all,
    My 30" cinema display has worked fine since I got it (used) a couple weeks ago. I tried moving it to another computer, and found that with the USB/Firewire connected, the display won't turn on. Unplug them, and it works fine. I had them plugged in when it was attached to the other computer, and everything was fine, so it seems to be an intermittent problem.

    Does anyone know a solution for this?

    Thanks in advance

    Josh

  2. #2


    Member Since
    Jan 04, 2010
    Posts
    1
    Quote Originally Posted by Josh Behan View Post
    Hey all,
    My 30" cinema display has worked fine since I got it (used) a couple weeks ago. I tried moving it to another computer, and found that with the USB/Firewire connected, the display won't turn on. Unplug them, and it works fine. I had them plugged in when it was attached to the other computer, and everything was fine, so it seems to be an intermittent problem.

    Does anyone know a solution for this?

    Thanks in advance

    Josh
    Hello Josh.

    I'm having exactly the same problem with my smaller 23" cinema display. Its worked fine for several years, and then suddenly no longer works if (and only if) the USB and/or the firewire cables are connected to the Mac. I've tried other Mac computers and its the same!

    Did you resolve the issue?

    Thanks.

  3. #3

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    22,272
    Specs:
    Imac 27" Retina 5K, 512GB flash memory, 3.3GHz, 16GB memory, macOS Sierra beta.
    Scroll through these links from Apple Discussions:-

    Apple - Support - Discussions - USB and Firewire not working ...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Turn off Cinema display
    By mknabster in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 10-29-2012, 11:03 PM
  2. MBP: losing sound connected to Cinema display?
    By C-photo in forum Apple Notebooks
    Replies: 6
    Last Post: 12-04-2010, 05:05 AM
  3. MacBook won't turn on unless connected to the charger
    By devix91 in forum Apple Notebooks
    Replies: 2
    Last Post: 09-11-2007, 05:07 PM
  4. iPod won't turn on even when its connected to Power.. (Please Look)
    By nadasive in forum iPod Hardware and Accessories
    Replies: 3
    Last Post: 08-14-2007, 12:32 AM
  5. 23" Cinema HD - won't turn on....
    By masamune__ in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 07-21-2007, 04:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •