Results 1 to 2 of 2
  1. #1

    Member Since
    Oct 18, 2009
    Garmin 765T Won't mount on imac
    My garmin 765T won't mount on my powerpc imac. I am running system 10.4.11. The nuvi drive shows in the system info device box but will not show on the desk top on in disk utility. I have mounted it on a friend's mac and it worked fine--so the issue definitely seems to be my mac. I have reinstalled my system and that did not help. I've seen the problem discussed in a number of forums, but no solutions that anyone has said has worked...

    any help, please...

  2. #2

    Sur3Mac's Avatar
    Member Since
    Aug 03, 2009
    The Netherlands
    Late 2011 MBP 13" i5/16GB RAM,Early 2007 MB white 13", 2x TV 3rd Gen, ᣦ
    you can create a test user and configure your device on it.

    If it works the problem is in your user account... and you need to delete some garmin preferences in your user account


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iMac: Internal drive won't mount
    By ned911 in forum Apple Desktops
    Replies: 4
    Last Post: 11-30-2012, 06:09 PM
  2. WD Passport won't mount
    By jsinger21 in forum OS X - Operating System
    Replies: 0
    Last Post: 11-05-2012, 01:10 AM
  3. Garmin Map on iMac
    By Bundy in forum OS X - Apps and Games
    Replies: 2
    Last Post: 02-25-2012, 04:49 PM
  4. Script to mount volume (external drive or disk image) which won't mount..?
    By MaccIngs in forum OS X - Development and Darwin
    Replies: 2
    Last Post: 09-09-2011, 10:05 PM
  5. iMac won't mount FAT32 USB
    By Head_Unit in forum Apple Desktops
    Replies: 6
    Last Post: 08-29-2011, 07:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts