Results 1 to 5 of 5
  1. #1


    Member Since
    Nov 06, 2007
    Posts
    35
    Unhappy External HD isn't mounting
    Hi guys,

    I have a G4 powerbook, and I've recently bought a new external HD - Western Digital My Passport Essential 320GB USB 2.0 Portable Hard Drive.

    I looked on the reviews before I bought it, and the mac folk had no problems with it, I double checked an my USBs are Bus Power (mA): 500 - which means it should work with my HD (?)

    Can anyone suggest what I should do before I resort to sending it back.

    Thanks mucho!

  2. #2

    Kevriano's Avatar
    Member Since
    Jul 02, 2006
    Location
    Crawley, England
    Posts
    4,558
    Specs:
    20" Intel iMac 2.4 Ghz/3G Ram/320HD, Snow Leopard. PBook G4, 1.5Ghz/1.5 Ram/250 HD, Leopard 10.5.6.
    Did the HD come with a driver package? My old WD did.
    Try my custom Mac Forums Search Engine: Mac Forums Google Search

    Please use the reputation system if you consider any help given useful (it's the little ✓/✘ on the left <---)


  3. #3


    Member Since
    Nov 06, 2007
    Posts
    35
    No I don't think so - apparently its on the HD itself - but that is for PC. For the mac its meant to be plug n play.

  4. #4

    Kevriano's Avatar
    Member Since
    Jul 02, 2006
    Location
    Crawley, England
    Posts
    4,558
    Specs:
    20" Intel iMac 2.4 Ghz/3G Ram/320HD, Snow Leopard. PBook G4, 1.5Ghz/1.5 Ram/250 HD, Leopard 10.5.6.
    Ok. Mine had to install a driver, but anyway...

    Open disk utility and see if the drive shows up there, because this may be a format issue. It will need to be formatted to FAT32 if you intend to use it on a PC as well, or Mac OS Extended for the Mac only.
    Try my custom Mac Forums Search Engine: Mac Forums Google Search

    Please use the reputation system if you consider any help given useful (it's the little ✓/✘ on the left <---)


  5. #5


    Member Since
    Nov 06, 2007
    Posts
    35
    I've opened disk utility and it doesn't show in there either.

    Thanks for replying btw.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. mounting an external HD in 10.5.8
    By Little Wilk in forum OS X - Operating System
    Replies: 1
    Last Post: 11-14-2012, 03:20 PM
  2. External HD not mounting
    By aquahelix in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 03-08-2011, 02:05 PM
  3. Help with Mounting External HD
    By roblo in forum Apple Notebooks
    Replies: 3
    Last Post: 08-22-2010, 09:09 PM
  4. External Rock 400GB External HDD isn't recognizable after restarting computer?
    By xjxaxcxkx13 in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 08-08-2009, 02:44 AM
  5. Need Help w/ mounting an external HD please?
    By kmf886 in forum Other Hardware and Peripherals
    Replies: 8
    Last Post: 01-16-2007, 08:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •