Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Other Hardware and Peripherals (http://www.mac-forums.com/forums/other-hardware-peripherals/)
-   -   External HDD folder now Unix Executable (http://www.mac-forums.com/forums/other-hardware-peripherals/156622-external-hdd-folder-now-unix-executable.html)

enchanted_angel 06-23-2009 11:42 PM

External HDD folder now Unix Executable
 
Just bought a new WD external drive and everything was working fine until I tried to copy some movie onto my brother's PC. The Movie folder on my external drive now reads as a Unix executable on my Macbook...? The data is still there on the drive I'm sure as it all shows up when I tried it again on the PC. Can anyone please show me how to change this folder so my Macbook will read and open the folder again?

Please help as they're family videos that are very precious to me!

Big Dan 06-23-2009 11:50 PM

I'm not in OS X right now but you should be able to write click and set the properties of the folder to not be executable.

You can use this nice GUI app to remove the excutable permissions: Home of BatChmod

If not, open terminal cd (change directory) into the root folder of your extenal then chmod -R -x Movies/

That's tell it to remove the executable flag of the Movies folder and everything under it.

enchanted_angel 06-24-2009 12:28 AM

I'm sorry but I'm kinda new at using terminal... when I go into the root and use Big Dan's given command line, it tells me that "chmod: Movies/: Not a directory"

Which permissions should I be removing if I use the BatChmod program? I'm so confused... :S

Big Dan 06-24-2009 12:53 AM

You should be removing the executable permissions. Again I'm not back in OS X so I cannot open up BatChmod but it should be as simple as unchecking a little box either one that says Allow Executing Program as a file or by X under folder permissions.

I'm not sure of what permissions the external should be set at, every OS is different a normally / owns the drive.


All times are GMT -4. The time now is 05:19 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.