Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Other Hardware and Peripherals (http://www.mac-forums.com/forums/other-hardware-peripherals/)
-   -   printer won't print b&w even when selected (http://www.mac-forums.com/forums/other-hardware-peripherals/149887-printer-wont-print-b-w-even-when-selected.html)

rcronin 04-24-2009 09:02 AM

printer won't print b&w even when selected
 
I have a mystery.

I have the same hardware as last month, but now it works differently.

I have a Macbook and am printing to an HP deskjet 940c. I can't get it to print in B&W even when it's selected in the print dialog box. I can get the same printer to do B&W from my PC. When I go to the printers utilities it to check the ink level (the cartridge was just refilled) it says there is an error and it can't determine the ink levels. The printer's utilities dialog box shows the color one with a little ink and the B&W graph is just empty.

I have deleted and reinstalled the drivers several times, shutdown, rebooted multiple times.

I attempted to use Utiltities>Printer Set Up, but there's nothing there.

Any help?

What I am trying to print is a grayscale document from InDesign. But no matter what I do, it prints in (bad) color.

I have printed a document from TextEdit and it prints in B&W. Quite strange...

Thank you! :)

chscag 04-24-2009 01:19 PM

This may have more to do with the refilled cartridge you're using. (I'm assuming it's not the more expensive HP factory cartridge) If the software "thinks" the BW cartridge is empty, the result will be a mix of colors.

I have had similar problems with older HP DeskJet printers even in Windows but usually was able to implement a work around. I don't know of a work around for using the 940C with a refilled cartridge. TextEdit prints OK because it does not check ink levels.

One reason why I still keep an older model HP LaserJet around - for those fast grey scale or BW jobs I need to print. No fuss. :)

Regards.

rcronin 04-24-2009 01:52 PM

that makes sense. It's been refilled a few times, maybe I've passed the sweet spot and this is it for now.

Thank you!

cwa107 04-24-2009 02:48 PM

It might not be a bad idea to check HP's website and see if they have an updated driver for it, as well.

rcronin 04-26-2009 09:16 PM

The font drivers that I found were quite a few years old. The newest one I found was from 2006.

I had seen a webpage somewhere that described how to delete your drivers, there were several locations on the HD. But I can't find that now. I thought it was on Apple's website. I'm wondering if I haven't properly deleted the old driver.

I also tried printing the document from Preview and it still printed in color. So annoying!

Could this have happened during a software update? I can understand why it is happening now, when all the hardware is exactly the same. grrr.

harryb2448 04-27-2009 12:29 AM

Further to csschag's post, when the cartridge has been refilled several times, the sensor on the front of the cartridge may well fail giving one of two responses. On e is printing in colour, the second is repeatedly telling you there is no black cartridge installed when obviously there is.

Toss in a new black cartridge and see how you go?


All times are GMT -4. The time now is 03:29 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.