New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Other Hardware and Peripherals Other Apple systems and peripherals discussion.

MacBook Pro - external monitor color problem - DVI to VGA


Post Reply New Thread Subscribe

 
Thread Tools
djbreul

 
Member Since: Apr 05, 2009
Posts: 6
djbreul is on a distinguished road

djbreul is offline
I'm hoping someone out there can help me out with this.

Macbook Pro last years model. I use external monitors alot for video DJing. I normally go DVI to VGA using the adaptor that came with the MBP. The other night I tried a different adaptor- DVI to composite. Now when I go back to the DVI to VGA my external screens have a yellow green tinge to them. I bought a new DVI to VGA adaptor and that didnt help. I calibrated the color profile, detected displays. and still the external screens are a yellow green color. You can still see whatever Im playing but there is definately something wrong with the color.

Please Help me if you can. I use this computer 4 nights a week for work and I need it to be working good.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 38,403
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is online now
The original display profile (DVI to VGA) may have been overwritten when you switched to the DVI to Composite cable, but should have gone back to the original when you again used the DVI to VGA cable.

Let's try deleting the display profile files for each of your external monitors and see if that will get rid of the problem.

Navigate to /Library/ColorSync/Profiles/Displays/ Look for the name of each of your external monitors and move the individual display profile files to your desktop.

A new display profile file should automatically be created for each monitor when attaching them to the MBP. If all returns to normal, you can delete the old display profile files.

Regards.
QUOTE Thanks
djbreul

 
Member Since: Apr 05, 2009
Posts: 6
djbreul is on a distinguished road

djbreul is offline
i tried moving the profile and that didnt work.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 38,403
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is online now
When you go back to the DVI to composite adapter, do the external monitor screens return to normal?

Also, how about the internal screen display on the MBP? Are you operating in mirror mode or extended desktop mode? And is the internal screen on the MBP OK?

Post back.

Regards.
QUOTE Thanks
djbreul

 
Member Since: Apr 05, 2009
Posts: 6
djbreul is on a distinguished road

djbreul is offline
yes, when i go back to the DVI composite adaptor, the external screens go back to normal.
The internal MBP screen is just fine. I have tried both mirror & extended. still yellow.

mike
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 38,403
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is online now
OK. That means the graphics and display within your MBP are operating normally. We just haven't found out where the information regarding the monitor profile is being stored. Normally it's stored in the files I asked you to move to the desktop.

What make model of external monitor(s) are you using? I'm just wondering if the problem is not with the internal settings of the MBP but rather the monitor(s) themselves. I've had strange things occur with certain external monitors that required a complete reset of the monitor settings back to factory default before I could get it working properly.

If your monitor(s) have a reset back to factory default setting, try doing that and see if things return to normal. I'm hoping the monitor is "remembering" the composite settings and that's why the display is wrong.

Regards.
QUOTE Thanks
djbreul

 
Member Since: Apr 05, 2009
Posts: 6
djbreul is on a distinguished road

djbreul is offline
I have tried4 different monitors with the same result. Yellow.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 38,403
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is online now
Quote:
Originally Posted by djbreul View Post
I have tried4 different monitors with the same result. Yellow.
We're probably dealing with a system file somewhere that has been changed and we can't find it. There are several system files which depict display preference or have to do with the hardware setup. I would hate to start using a "shotgun" approach to deleting or moving them without knowing for sure which one was safe to do so.

Do you have a backup (Time Machine or otherwise) that you could use to restore the system to before you changed out the cable? Or perhaps restoring from backup would be inconvenient and would involve a loss of data?

My next suggestion is to contact Apple support if your machine is still under warranty or Apple care and run the problem by them. Perhaps someone there may know which file or files can be edited or removed to get things back to normal.

Regards.
QUOTE Thanks
djbreul

 
Member Since: Apr 05, 2009
Posts: 6
djbreul is on a distinguished road

djbreul is offline
I didnt back it up. But all my important files are actually on an external. So maybe if all else fails I can just wipe the system and start over?

Im taking it to the Mac Store today.
we'll see.
QUOTE Thanks
djbreul

 
Member Since: Apr 05, 2009
Posts: 6
djbreul is on a distinguished road

djbreul is offline
so i took it to the Mac store. They couldnt figure it out. So I reinstalled the system software along with everything else. Still the external screen is a green yellow color. I think that this is telling me that there is a problem with the video card.
what do you think?
QUOTE Thanks
macforumpass

 
Member Since: Apr 14, 2009
Posts: 2
macforumpass is on a distinguished road

macforumpass is offline
Quote:
Originally Posted by djbreul View Post
so i took it to the Mac store. They couldnt figure it out. So I reinstalled the system software along with everything else. Still the external screen is a green yellow color. I think that this is telling me that there is a problem with the video card.
what do you think?

There is no problem with your video card, it is a matter of getting the OLDER type VGA monitors to work with the adapter. The signals for the various rgb components get switched improperly, there is a fix for this in some obscure setting.

I will try and track it down and post here.
QUOTE Thanks
macforumpass

 
Member Since: Apr 14, 2009
Posts: 2
macforumpass is on a distinguished road

macforumpass is offline
Has SOMETHING to do with the Apple DVI -> VGA adapter being "too compliant" -- apparently the extra DVI pins get tricked by low quality VGA and somehow disable the wrong color channel.

Quick and dirty "fix": do NOT screw-in the adapter all the way, so the the portion nearest the back of the MacBookPro is about 1/16" away from fully seated. This will result in the extra pins NOT being connected and the VGA signal will look fine. Some folks have gone so far as to clip off the extra pins...
QUOTE Thanks
Sander

 
Member Since: May 15, 2009
Posts: 1
Sander is on a distinguished road

Sander is offline
I've the same problem with my Macbook: the green screen when I connect it by DVI connector to an external display.

But not always!

When I pull/lift the DVI connector up while it is plugged in, normal colors appear! It is getting worse and worse unfortunately, and it's a nuisance when giving presentations to first have to carefully find the exact way to hang the display wire in the air...

But in my case, it seems like a hardware problem. So I just had to write about it in this thread, and I'm curious to hear from others experiencing the same problem, does this 'fix' it temporarely too on your machines?
QUOTE Thanks
phillyh

 
Member Since: Nov 15, 2009
Posts: 1
phillyh is on a distinguished road

phillyh is offline
Quote:
Originally Posted by Sander View Post
When I pull/lift the DVI connector up while it is plugged in, normal colors appear! It is getting worse and worse unfortunately, and it's a nuisance when giving presentations to first have to carefully find the exact way to hang the display wire in the air...
Looks like this is a pretty old thread, but...

I'm currently dealing with the same problem - the adapter for my Macbook shows yellow on the external monitor unless I prop it up with something, but my coworker's is totally normal. Guess I should try the quick and dirty fix!

I can't understand why these adapters are so poorly designed. The plug-and-go functionality is nice but they just don't hold well enough!
QUOTE Thanks
anaisafranco

 
Member Since: Dec 11, 2009
Posts: 1
anaisafranco is on a distinguished road

anaisafranco is offline
Hi folks,

I have the same problem.
I have a MacBook Pro 15 inch and I could never use a projector using the DVI to VGA adaptor because it has a yellow tint when projects the image.
I just can use my computer with s-video adapter which is very boring.

Does anyone discovery how to fix this problem?

cheers
QUOTE Thanks

Post Reply New Thread Subscribe


« Old HD no good? Best next steps? | Airport express worked for a month now doesn't, help! »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Late 2008 MacBook Pro, External Display Won't Come Back On After Screen Shuts Off RocketMan85 Apple Notebooks 3 11-23-2008 04:34 AM
Trying to run new 20" Cinema display with older style DVI port asiageof Apple Desktops 1 11-10-2008 01:12 PM
DVI VGA adapter rtpguy5 Switcher Hangout 0 07-04-2007 10:36 PM
DVI to VGA for Desktop LCD...& Faster External Hard Drives..? Migraine Apple Desktops 1 03-22-2005 06:01 PM

All times are GMT -4. The time now is 06:53 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?