Results 1 to 2 of 2

Thread: lightscibe

  1. #1

    Member Since
    Jul 28, 2008
    Ok have a few probs with lightscribe on my mac got me completly foxed!!

    brought my powermac g5 last year and its been best thing i've ever done great buy have got my pc but never use it till this week!!

    when i brought the g5 thought the only thing i'm missing is my lightscribe so brought a internal lightscribe dvd recorder off e-bay thought no more of it.

    Anyway brought a copy of toast which was lightscibe compatible so thought i was ok anyway this week week did a wedding went to burn disc no prob went to lightscribe it
    and this message came up

    LightScribe device is not ready to print. Please check the following:

    - The device is switched on;
    - The latest version of Host software is installed.

    Host software can be found on the install CD or

    went to the roxio page and downloaded latest version of lightscribe firmware and tried lightscribe page itself but also no luck tried to update superdrive firmware for the dvd recorder but it says not needed also tried different software still no luck was wondering if any of you clever mac people in here knew what i was doing wrong ???


    mick hall

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    This may sound silly, but are you using LightScribe media to print to? That message and similar ones will display if you're trying to write to ordinary media not designed for LightScribe printing.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts