Results 1 to 4 of 4
  1. #1

    Member Since
    Oct 30, 2007
    Problem with Spotlight search criteria - ITS MISSING!
    Here is a screenshot of the typical spotlight window on a 10.5.2 machine (Intel Mac Pro):

    Here is a screenshot of the same window after I click the '+' sign to add an additional search criteria value:

    In the second screenshot, that extra blank space at the bottom is where is supposed to say Name: or Kind: etc...but its just not there and I have no idea why??

    I have tried creating a new user account on my machine to see if the same issue occurred their as well, and sure enough, it does not.

    I have tried all sorts of maintenance and repair tactics to resolve the issue (such as repairing permissions, running DIsk Warrior, Cocktail, Onyx, Leopard Cache Cleaner, etc...) but nothing seems to resolve the issue??

    Anyone have any thoughts as to what the issue might be, and how I can go about fixing it?

    FYI - In case any does know of any third-party apps that might cause this issue, below are a few screenshots showing some of the apps, system preferences, and processes running on my machine:

    Applications Folder:

    System Preferences:

    My Processes:

  2. #2

    Member Since
    Oct 30, 2007
    I checked the console for error messages upon expanding the finder window search criteria menu, and it resulted in the following message being generated...

    Finder [242]

    HIToolbox: ignoring exception 'Delete returned nil for call to ruleEditor:0x1c1247d0 displayValueForCriterion:0x51c760 inRow:0' that raised inside Carbon event dispatch

    Anyone have any idea what this means?

  3. #3

    Member Since
    Oct 30, 2007
    OK, so this is a weird one...I found this link in searching the net for a solution to my problem, in which some other guy who was having the exact same issue managed to resolve his problem by...get this...trashing his file, then instead of just restarting (which didn't work for him, or for me to resolve the issue) instead, immediately after trashing the file, holding down the power button for 5 seconds to force-shutdown

    Low and behold, I tried it and it worked!! The issue is not an issue anymore!

  4. #4

    Member Since
    Mar 11, 2004
    After tossing out the plist, a regular restart probably would have worked. Without a restart, forced or not, the machine had read and loaded the old plist when it had started and continued using it after it was trashed.

    An aside: Funny how that problem is a seeming holdover from pre-OS X systems. Whether a preferences file in System 9 and earlier or a preferences-list file in X, the problem and the cure is the same. Trash it and restart.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Spotlight search preferences?
    By RobertBullwinke in forum OS X - Operating System
    Replies: 1
    Last Post: 05-03-2011, 02:20 PM
  2. Are there some places Spotlight can't search?
    By fleurya in forum OS X - Operating System
    Replies: 2
    Last Post: 04-28-2008, 03:55 AM
  3. Spotlight search in Entourage
    By climbguy in forum Switcher Hangout
    Replies: 1
    Last Post: 09-12-2006, 06:58 PM
  4. Question on Spotlight Search
    By Back2MacinNYC in forum Switcher Hangout
    Replies: 4
    Last Post: 06-24-2006, 06:52 PM
  5. search and spotlight
    By MendoOza in forum OS X - Operating System
    Replies: 0
    Last Post: 05-24-2006, 06:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts