Results 1 to 7 of 7
  1. #1

    Member Since
    Jan 20, 2008
    2.16GHzCoreDuo 160Gb
    Canīt empty trash...
    I don´t know what tells me that the trash is in use...Downloaded firefox cause of some prob with hotmail. Can not eject from my desktop...

  2. #2

    Member Since
    Jan 06, 2008
    Hillbank, South Australia
    2 x 20" iMac Intel Core 2 Duo
    maybe you are using firefox from the mounted image instead of the installed APP?

    Also try the secure trash empty choice from finder.

  3. #3

    mac57's Avatar
    Member Since
    Apr 29, 2006
    St. Somewhere
    iMac 27" 3.4 GHz, 256 GB SSD, 2 TB HDD, 8 GB RAM
    This happens from time to time, for reasons I am not sure of. When I run into this, I just reboot. Then I can empty the trash and all is well again. I don't know what the root cause is, nor what the REAL solution is, but this work around does me fine. If it happened a lot, this would be annoying, but it only happens once every few months.
    My Macs: iMac 27" 3.4 GHz, Mac Pro 3.2 GHz, PowerMac G5 Quad 2.5 GHz, G4 Cube with 1.2 GHz Upgrade
    My iStuff: 64GB iPhone 5, 64GB iPad4, 30GB iPod Video, 16GB iPod Touch
    My OS': Mac OS X Lion, Mac OS X Snow Leopard, Mac OS X Tiger, Mac OS 9.2.2, openSUSE 10.3
    I was on the Mac-Forums honor roll for September 2007

  4. #4

    mikepugs's Avatar
    Member Since
    Sep 20, 2007
    West Chester, PA
    15" Macbook Pro 2.66 GHz, 4GB 1067 MHz running Snow Leopard
    One of your apps is running and using something you put in the trash. Make sure you've copied files from anything you've ejected or haven't accidentally put a necessary file in there. Check that and if you can't figure it out quit all your apps and try again. If that still doesn't work simply reboot and empty.
    l 8GB iPhone 3G l 15" Macbook Pro l Powerbook G4 15" l 8GB iPod Touch l 4GB iPod Mini l

  5. #5

    iLindzo's Avatar
    Member Since
    Nov 01, 2007
    Bay Area, CA
    15" MBP w/Intel Core 2 Duo w/Lion, MBA w/Lion, 80GB iPod Video, 32GB iPhone 4, Two 32GB iPads
    a) Reboot

    b) Quit all apps and try again

    c) Use THIS.

    It's a Force Empty Trash
    Mac users swear by their computers. PC users swear at their computers.

  6. #6

    Member Since
    Jan 20, 2008
    2.16GHzCoreDuo 160Gb
    as I started it today it was okay, all the crap was ejected from my desktop and I removed firefox. Someone told me that it runs better with that crap but safari is doing a better job...cheers!

    mac...really old G4 or sumfin, it's lout and massive but I'm lovin it!

  7. #7

    mck_tj05's Avatar
    Member Since
    Apr 20, 2007
    little bit north of dallas
    MBP C2D, 1 GB ram, 120GB HD
    this happened to me once, then i called apple. they told me to hold down the alt/option key and then click on "empty trash". worked like a miracle!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 04-21-2013, 09:11 AM
  2. Secure Empty Trash + Empty Free Space
    By Daragon in forum OS X - Operating System
    Replies: 1
    Last Post: 12-03-2012, 12:46 AM
  3. Can't Empty or Secure Empty Trash
    By leopard-user1 in forum OS X - Operating System
    Replies: 15
    Last Post: 12-07-2010, 03:32 PM
  4. The difference between secure empty and just empty trash?
    By stevo-m in forum OS X - Operating System
    Replies: 10
    Last Post: 09-07-2007, 09:13 PM
  5. Can't empty the Trash
    By aintor in forum OS X - Operating System
    Replies: 9
    Last Post: 04-02-2007, 08:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts