Results 1 to 5 of 5

Thread: Please help!

  1. #1

    stevegate's Avatar
    Member Since
    Oct 02, 2007
    Please help!

    MBP(2 month old) 2.4 GHZ, 2 GB Ram, 160 GB HDD

    I just got the error report after restarting my MBP, the problem happened when I plug my external HD that I use for Time machine. I don't know if this error come from this external HD? I keep recieving this error report until I plug out the ext HD.

    I have no clue what is really happning here, any advice would be appreciated. Thank you

    Sat Nov 3 22:28:38 2007
    panic(cpu 0 caller 0x003144B7): "btree_swap_node: about to write corrupt node!\n"@/SourceCache/xnu/xnu-1228/bsd/hfs/hfs_btreeio.c:197
    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x41c737f8 : 0x12b0e1 (0x4555b4 0x41c7382c 0x133238 0x0)
    0x41c73848 : 0x3144b7 (0x480484 0x6338200 0x1 0x10b1f60)
    0x41c73888 : 0x1f8071 (0x303727b0 0x62ca804 0x0 0x0)
    0x41c73948 : 0x1f89c1 (0x0 0x41c7396c 0x0 0x0)
    0x41c73988 : 0x33bdfe (0x435ce08 0x1 0x2 0x4844b0)
    0x41c73a18 : 0x32ade9 (0x6337090 0x1 0x1 0x43ebbc0)
    0x41c73a98 : 0x1f3e66 (0x41c73ac8 0x246 0x41c73af8 0x1d803e)
    0x41c73af8 : 0x365980 (0x6337090 0x33 0x0 0x0)
    0x41c73f78 : 0x3da8b0 (0x43ebbc0 0x487e1e0 0x487e224 0x0)
    0x41c73fc8 : 0x19ea34 (0x48798c0 0x0 0x1a10b5 0x4883998)
    No mapping exists for frame pointer
    Backtrace terminated-invalid frame pointer 0xb05928b8

    BSD process name corresponding to current thread: mds

    Mac OS version:

    Kernel version:
    Darwin Kernel Version 9.0.0: Tue Oct 9 21:35:55 PDT 2007; root:xnu-1228~1/RELEASE_I386
    System model name: MacBookPro3,1 (Mac-F4238BC8)

  2. #2

    MacsWork's Avatar
    Member Since
    May 22, 2005
    Closer than you think.
    Performa 6116 2GBSCSI 8MB OS 7.5.3
    Turn off time machine and select "none" as the disk choice. Then plug in the ext HD.

    You may need to repair the HD, or perhaps format it again.

  3. #3

    schweb's Avatar
    Member Since
    Oct 27, 2002
    Cleveland, Ohio
    MacBook Pro | LED Cinema Display | iPhone 4 | iPad 2
    In addition, you may want to read this thread on thread subjects, it may help you get more help than the title you've used:
    schweb | community leader
    flickr facebook twitter tumblr google+

    Mac-Forums: On Twitter | On Facebook | On Flickr

  4. #4

    stevegate's Avatar
    Member Since
    Oct 02, 2007
    Finally it works again.
    Quote Originally Posted by MacsWork View Post
    Turn off time machine and select "none" as the disk choice. Then plug in the ext HD.

    You may need to repair the HD, or perhaps format it again.
    Thank you for your advice, this works like charm. Howerver, I did find out the problem before I read your advice, but what you said is very correct. I had to stop time machine first and I plug out ext HD. I plug it in another my iMac and earse.

    Well, I had big problem here. The iMac did not regconize this ext HD either, I am not so worry because I bought this ext HD about 5 days ago and it is in warranty. The ext HD i bought was Seagate FreeAgent Go 160GB 2,5" . I bought this ext HD before I read the thread about Warning on Seagate HD. I don't know if this is error come from Seagate but I fixed it anyway.

    I had to plug it in another machine running windows, boot from Hiren 9.3 cd, and and go to Partition section, there are many kind of partition tools here. First I chose Partition magic pro, it did not work. What I saw is the yellow blank with the name BAD on it indicated on my ext HD, I could not format it either. It ran but error in the middle way.

    Then I chose another partition tool, Acronis Disk Director Suite. Well, with this tool I could see the optition Delete partition is visible so I delete partition and create a new partition unformatted.

    I plug it in my iMac again and now I can see it in Disk Utility. I erase my ext HD with Zero out data and I chose volume format is Mac OS Extended(Jourlaned). I took about 2 hours.

    After that I came back with my MBP and tried it on. I worked perfectly. Well, I am still confuse if this problem happended because of hardware?? I hope not, I bought this ext Seagate because I can have 5 years warranty.

    I hope this help for the one who have the same problem with me. Good luck and cheers.

    To the ADMIN: I am sorry that I put the title like that, anyway, I am new in this forum and did not read the rule so much.

  5. #5

    Member Since
    Aug 04, 2007
    Its most likely a corrupted file system that has prevented the OS from 'seeing' the hard disk properly. A re-format normally corrects this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts