I'm running OS 10.3.4 and am having a major issue with Classic mode which I need to run my version of FileMaker, among other things.

First off, when Classic and a Classic app are running it noticeably slows down the rest of the system, even OSX-native apps. For example, with Classic, FileMaker in Classic mode, and IE5.2 running, IE jerks as it scrolls, menus take a split second longer to open, etc. If I shut Classic down everything returns to normal.

Second, textual apps like FileMaker and Word (also running in Classic) look like they're stuttering every few seconds... I can because for example, in Word the cursor will be blinking and then pause, blink a few more times and pause, each time pausing for half a second or so before returning to normal. This happens consistently. What's really aggravating about this is that if I'm typing in one of those programs, every few letters or so will exploded, so if I was typing "computer" at the time it might end up looking like "compuuuuuuuuter" even though I only pressed the key once. It's making working with X and my Classic programs damned near impossible.

I'm looking into upgrading these apps to Panther-native versions but for the time being, I'd really like to get this solved. I've tested another Mac in the office that is also running 10.3.4 and it has no problems whatsoever in either FileMaker of Word, so I know it has to be something with mine. I don't think hardware is an issue: I'm running a 1.3 Ghz processor (GigaDesigns), 9000 Radeon Mac ed., and 1.5 gigs of RAM... They should all be able to handle this with no problem, yet I'm getting this stupid jitters. I've tried doing all the regular maintenance like disk repair, permissions repair, etc. to no avail.

Any suggestions?